summaryrefslogtreecommitdiff
path: root/app-emulation/cloud-init/cloud-init-0.7.6_p1212.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /app-emulation/cloud-init/cloud-init-0.7.6_p1212.ebuild
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'app-emulation/cloud-init/cloud-init-0.7.6_p1212.ebuild')
-rw-r--r--app-emulation/cloud-init/cloud-init-0.7.6_p1212.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/app-emulation/cloud-init/cloud-init-0.7.6_p1212.ebuild b/app-emulation/cloud-init/cloud-init-0.7.6_p1212.ebuild
deleted file mode 100644
index 737e56a54944..000000000000
--- a/app-emulation/cloud-init/cloud-init-0.7.6_p1212.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-BZRTGZ=1
-
-inherit distutils-r1 eutils multilib systemd
-
-DESCRIPTION="EC2 initialisation magic"
-HOMEPAGE="https://launchpad.net/cloud-init"
-if [ "x$BZRTGZ" != x1 ]; then
- SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
-else
- # Launchpad does not provide consistent checksums https://bugs.launchpad.net/launchpad/+bug/1576338
- # SRC_URI="http://bazaar.launchpad.net/~${PN}-dev/${PN}/trunk/tarball/${PV/*_p} -> ${P}.tar.gz"
- SRC_URI="mirror://gentoo/${P}.tar.gz https://dev.gentoo.org/~robbat2/distfiles/${P}.tar.gz"
- S="${WORKDIR}/~cloud-init-dev/cloud-init/trunk/"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-CDEPEND="
- dev-python/cheetah[${PYTHON_USEDEP}]
- dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- dev-python/oauth[${PYTHON_USEDEP}]
- dev-python/prettytable[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${CDEPEND}
- >=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
- dev-python/mocker[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- ~dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
- dev-python/pyflakes[${PYTHON_USEDEP}]
- sys-apps/iproute2
- )
-"
-RDEPEND="
- ${CDEPEND}
- sys-fs/growpart
- virtual/logger
-"
-
-PATCHES=( "${FILESDIR}/cloud-init-0.7.6_p1212-gentoo.patch" )
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- emake test
-}
-
-python_install() {
- distutils-r1_python_install "--init-system=sysvinit_openrc"
-}
-
-python_install_all() {
- keepdir /etc/cloud
-
- distutils-r1_python_install_all
-
- insinto /etc/cloud/templates
- doins "${FILESDIR}/hosts.gentoo.tmpl"
- insinto /etc/cloud
- doins "${FILESDIR}/cloud.cfg"
-}