summaryrefslogtreecommitdiff
path: root/app-emulation/armv8-fast-model
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emulation/armv8-fast-model
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emulation/armv8-fast-model')
-rw-r--r--app-emulation/armv8-fast-model/Manifest5
-rw-r--r--app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild47
-rw-r--r--app-emulation/armv8-fast-model/metadata.xml8
3 files changed, 60 insertions, 0 deletions
diff --git a/app-emulation/armv8-fast-model/Manifest b/app-emulation/armv8-fast-model/Manifest
new file mode 100644
index 000000000000..3c3191329be2
--- /dev/null
+++ b/app-emulation/armv8-fast-model/Manifest
@@ -0,0 +1,5 @@
+DIST FM000-KT-00035-r0p8-52rel06.tgz 9429294 SHA256 a011c7549029fe5c475f2d495b225b93317a44eb3da0f19f2825ad831c64d899 SHA512 349470432e8dba9e52eba88b577b22fdd9e3ce865288a3dc1540c58e1e10b4f2c14f084f7a4928993e4d1d3bc7cfbbf235f2575394254f09a8d845b7b2993f12 WHIRLPOOL e95ed1315f264ed82f2debd903ad69a6437798d88727e275285d1d06c5da1a5841b9955e93b6dbdc446ad652ef383a37cfe0f43a3888f23ec428a67a765e6ac7
+EBUILD armv8-fast-model-0.8.5206.ebuild 1137 SHA256 37c36637c4dd7d3bda7db8d1e7d9b0377a6e70a30da07b6cb18b2a47cfa3a71b SHA512 34c49e9c9df3f13860baa825308ee2ff73d2f7f19beba294a0d812da325f1b5262607406bcca9b8e2f20fb13232138a92482d1289b123b9715e3b7e2740b768b WHIRLPOOL 640d3f0542bac423890f05d6179282228009d9693132e9be66e4e0f89b5a6758677f88b792560c22cb5319718721ee5a9a068e536dae059c6254151cd8d1dd2e
+MISC ChangeLog 2465 SHA256 6a2d9421799cc10cc4cfc2e78aa13ea5e1b8a637e6cedc667faf4f3e9b1a79f3 SHA512 161d425e56febc8e81982fdc8c39a52c87b2dbbea33183107d2eccb291a33bc08459276d29668bb5d36a70f22d3082e59849dad3af070ad47db66b9a2366a63b WHIRLPOOL ca0dcfacc6343e4099a0aa0f92b0162165ba4547bbd4c4c5226e009f1ad2a7e756c96fe5f72ff8d55717207496bab6baed06f0fd947c0287f9dd7fd328f9c9e4
+MISC ChangeLog-2015 401 SHA256 b3aabffbc548d40425237e14063d464816af3ea1223bf467a6cace7bb160f97c SHA512 afc86f241fd24865e1db62a22477434ac67807585b3f692e7d389abf810952415bd8abf39a796a65140c94e64afdc1fe48aae51e7a6d5f9b9cd971c07d7ed5dd WHIRLPOOL 651696dadc15d690aba45a5d975c3d981c049e9047efbdc737075826e8f19ca4eef8d17407eb184628baaf010bfd0f0d410c112ad2c97938ff23506b3497082c
+MISC metadata.xml 255 SHA256 2329f28bac0cd2e531f9e28d5d16d6c2f0a20878723e101565aefc5233b33531 SHA512 4408b5018e974df4d7508f29e255f318bbd09b4056927cae6406ff1f427c06d5d655f677a28440cb84af04e411c88e4582f9ad1ea76829afeee0bbe4e3841c2f WHIRLPOOL fc074050885e70dd142f3d3de3b966b62dd7bb1d095e6ab94f78962d8a1adebc6297fa3889093c3752e82afe170baece19e8458e9e2387b5ed52dbb6efe66e09
diff --git a/app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild b/app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild
new file mode 100644
index 000000000000..7d236f0f89cb
--- /dev/null
+++ b/app-emulation/armv8-fast-model/armv8-fast-model-0.8.5206.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils multilib
+
+MY_P="FM000-KT-00035-r${PV:0:1}p${PV:2:1}-${PV:0-4:2}rel${PV:0-2}"
+DESCRIPTION="emulator for a basic ARMv8 platform environment (for running bare metal & Linux)"
+HOMEPAGE="https://silver.arm.com/browse/FM00A"
+SRC_URI="https://silver.arm.com/download/Development_Tools/ESL:_Fast_Models/Fast_Models/${MY_P}/${MY_P}.tgz"
+
+LICENSE="ARM-FAST-MODEL"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="examples"
+RESTRICT="fetch strip"
+
+RDEPEND="sys-libs/glibc
+ sys-devel/gcc"
+
+S="${WORKDIR}/Foundation_v8pkg"
+
+QA_PREBUILT="
+ opt/${PN}/bin/Foundation_v8
+ opt/${PN}/*/lib*.so*
+"
+
+pkg_nofetch() {
+ einfo "Please visit this URL to download the package:"
+ einfo " ${SRC_URI}"
+ einfo "Then stick it into ${DISTDIR}"
+}
+
+src_install() {
+ into /opt/${PN}
+ pushd models/Linux64_GCC-4.1 >/dev/null
+ dobin Foundation_v8
+ dolib.so lib*.so*
+ popd >/dev/null
+
+ dodir /opt/bin
+ make_wrapper Foundation_v8 /opt/${PN}/bin/Foundation_v8 '' /opt/${PN}/$(get_libdir) /opt/bin
+
+ dodoc doc/*.{pdf,txt}
+ use examples && dodoc -r examples
+}
diff --git a/app-emulation/armv8-fast-model/metadata.xml b/app-emulation/armv8-fast-model/metadata.xml
new file mode 100644
index 000000000000..3101c4efc863
--- /dev/null
+++ b/app-emulation/armv8-fast-model/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>arm@gentoo.org</email>
+ <name>Gentoo Linux ARM Development</name>
+</maintainer>
+</pkgmetadata>