summaryrefslogtreecommitdiff
path: root/app-emulation/86Box
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
commit8fd9d385e5bc3c01115ec2ddcb2227607eb90861 (patch)
treeaba1e6ef6b95e94172c009394cd1fcbc383e7d6e /app-emulation/86Box
parent1ddcee0bd115d2f843f82061cb0d1741bf90151d (diff)
gentoo auto-resync : 05:01:2024 - 14:04:25
Diffstat (limited to 'app-emulation/86Box')
-rw-r--r--app-emulation/86Box/86Box-3.11.ebuild77
-rw-r--r--app-emulation/86Box/86Box-4.0.1-r1.ebuild4
-rw-r--r--app-emulation/86Box/86Box-4.0.ebuild77
-rw-r--r--app-emulation/86Box/Manifest7
-rw-r--r--app-emulation/86Box/files/86Box-4.0.1-incompatible-pointer-types.patch23
5 files changed, 28 insertions, 160 deletions
diff --git a/app-emulation/86Box/86Box-3.11.ebuild b/app-emulation/86Box/86Box-3.11.ebuild
deleted file mode 100644
index 1eb0faf7f95e..000000000000
--- a/app-emulation/86Box/86Box-3.11.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Emulator of x86-based machines based on PCem"
-HOMEPAGE="https://github.com/86Box/86Box"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="dinput experimental +fluidsynth +munt new-dynarec +openal +qt5 +threads"
-
-DEPEND="
- app-emulation/faudio
- dev-libs/libevdev
- media-libs/freetype:2=
- media-libs/libpng:=
- media-libs/libsdl2
- media-libs/openal
- media-libs/rtmidi
- net-libs/libslirp
- sys-libs/zlib
- qt5? ( x11-libs/libXi )
-"
-
-RDEPEND="
- ${DEPEND}
- fluidsynth? ( media-sound/fluidsynth )
- munt? ( media-libs/munt-mt32emu )
- openal? ( media-libs/openal )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qttranslations:5
- dev-qt/qtwidgets:5
- kde-frameworks/extra-cmake-modules
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- # LTO needs to be filtered
- # See https://bugs.gentoo.org/854507
- filter-lto
- append-flags -fno-strict-aliasing
-
- local mycmakeargs=(
- -DCPPTHREADS="$(usex threads)"
- -DDEV_BRANCH="$(usex experimental)"
- -DDINPUT="$(usex dinput)"
- -DDYNAREC="ON"
- -DSLIRP_EXTERNAL="ON"
- -DMUNT_EXTERNAL="$(usex munt)"
- -DFLUIDSYNTH="$(usex fluidsynth)"
- -DMINITRACE="OFF"
- -DMUNT="$(usex munt)"
- -DNEW_DYNAREC="$(usex new-dynarec)"
- -DOPENAL="$(usex openal)"
- -DPREFER_STATIC="OFF"
- -DQT="$(usex qt5)"
- -DRELEASE="ON"
- )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- elog "In order to use 86Box, you will need some roms for various emulated systems."
- elog "See https://github.com/86Box/roms for more information."
-}
diff --git a/app-emulation/86Box/86Box-4.0.1-r1.ebuild b/app-emulation/86Box/86Box-4.0.1-r1.ebuild
index cc978ae05ad0..16aac070243a 100644
--- a/app-emulation/86Box/86Box-4.0.1-r1.ebuild
+++ b/app-emulation/86Box/86Box-4.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -51,6 +51,8 @@ RDEPEND="
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${PN}-4.0.1-incompatible-pointer-types.patch" )
+
src_configure() {
# LTO needs to be filtered
# See https://bugs.gentoo.org/854507
diff --git a/app-emulation/86Box/86Box-4.0.ebuild b/app-emulation/86Box/86Box-4.0.ebuild
deleted file mode 100644
index e7aba1c39380..000000000000
--- a/app-emulation/86Box/86Box-4.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Emulator of x86-based machines based on PCem"
-HOMEPAGE="https://github.com/86Box/86Box"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="dinput experimental +fluidsynth +munt new-dynarec +openal +qt5 +threads"
-
-DEPEND="
- app-emulation/faudio
- dev-libs/libevdev
- media-libs/freetype:2=
- media-libs/libpng:=
- media-libs/libsdl2
- media-libs/openal
- media-libs/rtmidi
- net-libs/libslirp
- sys-libs/zlib
- qt5? ( x11-libs/libXi )
-"
-
-RDEPEND="
- ${DEPEND}
- fluidsynth? ( media-sound/fluidsynth )
- munt? ( media-libs/munt-mt32emu )
- openal? ( media-libs/openal )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qttranslations:5
- dev-qt/qtwidgets:5
- kde-frameworks/extra-cmake-modules
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- # LTO needs to be filtered
- # See https://bugs.gentoo.org/854507
- filter-lto
- append-flags -fno-strict-aliasing
-
- local mycmakeargs=(
- -DCPPTHREADS="$(usex threads)"
- -DDEV_BRANCH="$(usex experimental)"
- -DDINPUT="$(usex dinput)"
- -DDYNAREC="ON"
- -DMUNT_EXTERNAL="$(usex munt)"
- -DFLUIDSYNTH="$(usex fluidsynth)"
- -DMINITRACE="OFF"
- -DMUNT="$(usex munt)"
- -DNEW_DYNAREC="$(usex new-dynarec)"
- -DOPENAL="$(usex openal)"
- -DPREFER_STATIC="OFF"
- -DRTMIDI="ON"
- -DQT="$(usex qt5)"
- -DRELEASE="ON"
- )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- elog "In order to use 86Box, you will need some roms for various emulated systems."
- elog "See https://github.com/86Box/roms for more information."
-}
diff --git a/app-emulation/86Box/Manifest b/app-emulation/86Box/Manifest
index 7eb8bb6c4c4e..e5ce8caf4d09 100644
--- a/app-emulation/86Box/Manifest
+++ b/app-emulation/86Box/Manifest
@@ -1,7 +1,4 @@
-DIST 86Box-3.11.tar.gz 4593971 BLAKE2B 0b2771492910f0c11835104e5ef7495ca052414a959e27732ec0d72bc6a6f4cb46c386f0642042425cfd4c4aa1b16e24e027e53034ffae618d9c51aff282cdf7 SHA512 4705f0bb7186a19b8a74450132a73c01e9fae80809e7cebf2ef0294100081ff6a27e0f81dbc661596a8d1cd7b04afc5dddb3e990dd10951a37a48de338c49a77
+AUX 86Box-4.0.1-incompatible-pointer-types.patch 826 BLAKE2B 79080877c25dc1292e743a03225ec95994284d7999443da91e81f492dc2c7e8d7e2987304fbb21b62c3cb6406a175c90f821963822db609436cf10fee36077e3 SHA512 270960bfad2b99b0c4c8d7e3b889f0601490ed780c5ddde619efdb57bdf6d20309e079b77a986625a7824bbc5dce47199a1534be0bef0b9448221ff52cab5457
DIST 86Box-4.0.1.tar.gz 5206128 BLAKE2B 56a4d374757eb67368bbc5782bceca3f4dec79dd36fad6698065a86c3937238b352425dd856169a1a65a42a4f60f1a68b099ece4a7c019be4229d61fabfc444a SHA512 b06a8c50558276f35f98795e0513b5bd39eed3a0d3a8d61bf79b373501cd823ab3ab12fb943e879a240292bca39c507a1a42b1b6f3f9ae596499b685a03acf98
-DIST 86Box-4.0.tar.gz 5200746 BLAKE2B 74f702d7be42ee84a4ca337e13bb77ec3fb89b1e78018807d8ced63e474905799f1cf6bf7c093f17dedcc6da0c07b0283f9e2c490f3b3f7ba3c4f1689988b8d4 SHA512 8465e86e44bb5fa260f0550479e877a0f4a407eb59a00db8bab6764fecb292b8c9a370451eb71adbf84db990d7ea70e001cd1b2bc096c95caa7526901d20833e
-EBUILD 86Box-3.11.ebuild 1730 BLAKE2B 109ffe90a69d81fdf5f71091c2cba14e4f1793ef0140670bd78ab227f761a9497828504b1752a494a11f04d25af223f961486110e0d9be6695874197e724205f SHA512 fe7fa911a8f04c2def855fe830d2f89dffc41bb72c8a8e1e742ce4fe01c44b92d64c2e0a14c0dcc940cabd625828f1b29f33d8098ba3ad3caea86e2f2d5e1683
-EBUILD 86Box-4.0.1-r1.ebuild 1914 BLAKE2B 6e2c76bf8bdf21f288e00f549747aba658f787ffc7470b072a2af5c187936d8901234bd07ea937b155ac2ea34dfcedcf45473205ce8547e8e0fb55a32b1ea01b SHA512 c48a360e0bc5b2860db1ad544b8eaeeabc5369617ae44b16c7e4087f25c9215979a56615142fa7eeb4d38960d6cc10368cea561bdb8cb02a96d6b66610b2d81b
-EBUILD 86Box-4.0.ebuild 1722 BLAKE2B ac17d931d437b02a0f4dfd7d56ced50c6fc81d33f0ad099964204fb4c3f62557ee735bc7182d2f89f06a6388eb7f7f0aca8adb06ec2a444c39be31d3b61b5763 SHA512 46c30bfdd94995c3590729e86b28be1b58465d5080c2c592efed0d9aadb124de760a6ee9f5e3cdd14b80d4c366115f41c2b304f7a879c64827619c1bd9bf1e1b
+EBUILD 86Box-4.0.1-r1.ebuild 1986 BLAKE2B eec97b40da1265d7727cc8bc0112d5d6d307b498d4bc75f071b861183df9b4afdd5adb2ede1adf32ff207f7e4918b5da4bed42218c81a2b59aa0053194da649b SHA512 a36bbfc49c6fe1e40a3ac495304669a5d5fa0e4694da09cfefa6d3cb33d134a963d299f84685a22eba9a87f468e1cee443b67f2b1f2fdefb6242de95646442c7
MISC metadata.xml 1162 BLAKE2B 3293da00bec68462e7488dca4d16aa1a6f1e49be1bfd49b8ee5546e247440b7390f78089cc74293b62d18dec7ee0db4a80ed2de2d12401a1b5ebec80275f5646 SHA512 e0d1f641a1b3e751655b1665d4df758cfc648de47770552ce78d136946c322da4a0140358575fd3ed9adbb87d83aa4b28a6c8eda0be375fde0cd77b0b5718c9b
diff --git a/app-emulation/86Box/files/86Box-4.0.1-incompatible-pointer-types.patch b/app-emulation/86Box/files/86Box-4.0.1-incompatible-pointer-types.patch
new file mode 100644
index 000000000000..df708d337b65
--- /dev/null
+++ b/app-emulation/86Box/files/86Box-4.0.1-incompatible-pointer-types.patch
@@ -0,0 +1,23 @@
+From 13d582b56faf9caca114ec5625b34a7859ecb41f Mon Sep 17 00:00:00 2001
+From: OBattler <oubattler@gmail.com>
+Date: Fri, 5 Jan 2024 13:01:17 +0100
+Subject: [PATCH] Unix: Use proper parentheses to cast the result, not the
+ flags, fixes #3994.
+
+---
+ src/unix/unix.c | 4 +---
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/unix/unix.c b/src/unix/unix.c
+index e784df38e6..cfa8243135 100644
+--- a/src/unix/unix.c
++++ b/src/unix/unix.c
+@@ -635,7 +635,7 @@
+ SDL_MessageBoxData msgdata;
+ SDL_MessageBoxButtonData msgbtn;
+ if (!header)
+- header = (void *) (flags & MBX_ANSI) ? "86Box" : L"86Box";
++ header = (void *) ((flags & MBX_ANSI) ? "86Box" : L"86Box");
+ if (header <= (void *) 7168)
+ header = (void *) plat_get_string((int) header);
+ if (message <= (void *) 7168)