summaryrefslogtreecommitdiff
path: root/app-emulation/86Box
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-emulation/86Box
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-emulation/86Box')
-rw-r--r--app-emulation/86Box/86Box-3.3.ebuild67
-rw-r--r--app-emulation/86Box/Manifest3
-rw-r--r--app-emulation/86Box/metadata.xml25
3 files changed, 95 insertions, 0 deletions
diff --git a/app-emulation/86Box/86Box-3.3.ebuild b/app-emulation/86Box/86Box-3.3.ebuild
new file mode 100644
index 000000000000..6f4e3b3f01ac
--- /dev/null
+++ b/app-emulation/86Box/86Box-3.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Emulator of x86-based machines based on PCem"
+HOMEPAGE="https://github.com/86Box/86Box"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dinput +dynarec experimental +fluidsynth +munt new-dynarec +openal +qt5 +threads"
+
+DEPEND="
+ dev-libs/libevdev
+ media-libs/freetype:2=
+ media-libs/libpng:=
+ media-libs/libsdl2
+ media-libs/openal
+ media-libs/rtmidi
+ net-libs/libslirp
+ sys-libs/zlib
+"
+
+RDEPEND="
+ ${DEPEND}
+ fluidsynth? ( media-sound/fluidsynth )
+ munt? ( media-libs/munt-mt32emu )
+ openal? ( media-libs/openal )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qttranslations:5
+ dev-qt/qtwidgets:5
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCPPTHREADS="$(usex threads)"
+ -DDEV_BRANCH="$(usex experimental)"
+ -DDINPUT="$(usex dinput)"
+ -DDYNAREC="$(usex dynarec)"
+ -DFLUIDSYNTH="$(usex fluidsynth)"
+ -DMINITRACE="OFF"
+ -DMUNT="$(usex munt)"
+ -DNEW_DYNAREC="$(usex new-dynarec)"
+ -DOPENAL="$(usex openal)"
+ -DPREFER_STATIC="OFF"
+ -DQT="$(usex qt5)"
+ -DRELEASE="ON"
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "In order to use 86Box, you will need some roms for various emulated systems."
+ elog "See https://github.com/86Box/roms for more information."
+}
diff --git a/app-emulation/86Box/Manifest b/app-emulation/86Box/Manifest
new file mode 100644
index 000000000000..72677b0f50c3
--- /dev/null
+++ b/app-emulation/86Box/Manifest
@@ -0,0 +1,3 @@
+DIST 86Box-3.3.tar.gz 4017011 BLAKE2B f7d666e8a35cf500309bc02392f170d489c598c957d84a51f63cee870c7d12933c46964b555cf754587b926cfee3f6e99f07518e6c073996933e675b54dcd57e SHA512 c590b138d4cb19519847f13d8d68d6d8a54ee2372cb00e998dbb9b15d6c18beaa2e842625631fa716c1dba49149f1a93e8f6521a02d05d97b91ca311b8d91859
+EBUILD 86Box-3.3.ebuild 1484 BLAKE2B 6e21739893e2a939e318f08cba8badd5ce72d35b230c0e32113a61d2a716346e84497ce64dea81a34baf8e3a7ad17ad5bb846f1c3d5c8beab16493d1187e5da4 SHA512 76b70e4b083cc1706345409de57f2cc9db5c6ca6ca003d1d036e6fd32b98b06e20204678ceb99cca0d97b579e033276d5af1ae16d3ef132a7a42708daeccb0e1
+MISC metadata.xml 1266 BLAKE2B 45b789d3b456cf4fd28ab8ef5ab32bd8ef02c2da36f157a405ca2a90154d882f8c37a28dfa16cd6ea1e3d45d30ebd4130b37699792e0b1d0daf7ae32592e99a3 SHA512 8da4ab4b5d57caf7adc895d186ab3086857f196d2bc66513266305ace183f26f3b3304bbc861b7a31a95046d67bc7f008aa14d28c9848db9e09fae25724636f2
diff --git a/app-emulation/86Box/metadata.xml b/app-emulation/86Box/metadata.xml
new file mode 100644
index 000000000000..40e447a8f2ff
--- /dev/null
+++ b/app-emulation/86Box/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ 86Box is a low level x86 emulator that runs older operating systems and software
+ designed for IBM PC systems and compatibles from 1981 through
+ fairly recent system designs based on the PCI bus.
+ </longdescription>
+ <use>
+ <flag name="dinput">Enable legacy Dinput mode instead of Xinput for older controllers.</flag>
+ <flag name="dynarec">Enable dynamic recompiler, which should provide a better emulation speed.</flag>
+ <flag name="experimental">Enable hardware from devbranch, which may be unstable or unusable.</flag>
+ <flag name="fluidsynth">Enable MIDI support through <pkg>media-sound/fluidsynth</pkg>.</flag>
+ <flag name="munt">Enable MIDI MT-32 support through <pkg>media-libs/munt-mt32emu</pkg>.</flag>
+ <flag name="new-dynarec">Enable new dynamic recompiler from PCem 15, which should provide an even better emulation speed.</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/86Box/86Box/issues</bugs-to>
+ <remote-id type="github">86Box/86Box</remote-id>
+ </upstream>
+</pkgmetadata>