summaryrefslogtreecommitdiff
path: root/app-emulation/86Box
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 23:52:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 23:52:39 +0100
commit1b2c0d19f75523db182b267901484f87abf732cf (patch)
tree3c4832e97c3846189d07c64c2eba333bf33b8ab2 /app-emulation/86Box
parentdd851ab76c56a249df7a0ec052acd90940bc014f (diff)
gentoo auto-resync : 04:10:2023 - 23:52:39
Diffstat (limited to 'app-emulation/86Box')
-rw-r--r--app-emulation/86Box/86Box-4.0.ebuild77
-rw-r--r--app-emulation/86Box/Manifest2
2 files changed, 79 insertions, 0 deletions
diff --git a/app-emulation/86Box/86Box-4.0.ebuild b/app-emulation/86Box/86Box-4.0.ebuild
new file mode 100644
index 000000000000..e7aba1c39380
--- /dev/null
+++ b/app-emulation/86Box/86Box-4.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Emulator of x86-based machines based on PCem"
+HOMEPAGE="https://github.com/86Box/86Box"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dinput experimental +fluidsynth +munt new-dynarec +openal +qt5 +threads"
+
+DEPEND="
+ app-emulation/faudio
+ dev-libs/libevdev
+ media-libs/freetype:2=
+ media-libs/libpng:=
+ media-libs/libsdl2
+ media-libs/openal
+ media-libs/rtmidi
+ net-libs/libslirp
+ sys-libs/zlib
+ qt5? ( x11-libs/libXi )
+"
+
+RDEPEND="
+ ${DEPEND}
+ fluidsynth? ( media-sound/fluidsynth )
+ munt? ( media-libs/munt-mt32emu )
+ openal? ( media-libs/openal )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qttranslations:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/extra-cmake-modules
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ # LTO needs to be filtered
+ # See https://bugs.gentoo.org/854507
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ local mycmakeargs=(
+ -DCPPTHREADS="$(usex threads)"
+ -DDEV_BRANCH="$(usex experimental)"
+ -DDINPUT="$(usex dinput)"
+ -DDYNAREC="ON"
+ -DMUNT_EXTERNAL="$(usex munt)"
+ -DFLUIDSYNTH="$(usex fluidsynth)"
+ -DMINITRACE="OFF"
+ -DMUNT="$(usex munt)"
+ -DNEW_DYNAREC="$(usex new-dynarec)"
+ -DOPENAL="$(usex openal)"
+ -DPREFER_STATIC="OFF"
+ -DRTMIDI="ON"
+ -DQT="$(usex qt5)"
+ -DRELEASE="ON"
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "In order to use 86Box, you will need some roms for various emulated systems."
+ elog "See https://github.com/86Box/roms for more information."
+}
diff --git a/app-emulation/86Box/Manifest b/app-emulation/86Box/Manifest
index 5d9997baaeb6..92add11f981f 100644
--- a/app-emulation/86Box/Manifest
+++ b/app-emulation/86Box/Manifest
@@ -1,3 +1,5 @@
DIST 86Box-3.11.tar.gz 4593971 BLAKE2B 0b2771492910f0c11835104e5ef7495ca052414a959e27732ec0d72bc6a6f4cb46c386f0642042425cfd4c4aa1b16e24e027e53034ffae618d9c51aff282cdf7 SHA512 4705f0bb7186a19b8a74450132a73c01e9fae80809e7cebf2ef0294100081ff6a27e0f81dbc661596a8d1cd7b04afc5dddb3e990dd10951a37a48de338c49a77
+DIST 86Box-4.0.tar.gz 5200746 BLAKE2B 74f702d7be42ee84a4ca337e13bb77ec3fb89b1e78018807d8ced63e474905799f1cf6bf7c093f17dedcc6da0c07b0283f9e2c490f3b3f7ba3c4f1689988b8d4 SHA512 8465e86e44bb5fa260f0550479e877a0f4a407eb59a00db8bab6764fecb292b8c9a370451eb71adbf84db990d7ea70e001cd1b2bc096c95caa7526901d20833e
EBUILD 86Box-3.11.ebuild 1730 BLAKE2B 109ffe90a69d81fdf5f71091c2cba14e4f1793ef0140670bd78ab227f761a9497828504b1752a494a11f04d25af223f961486110e0d9be6695874197e724205f SHA512 fe7fa911a8f04c2def855fe830d2f89dffc41bb72c8a8e1e742ce4fe01c44b92d64c2e0a14c0dcc940cabd625828f1b29f33d8098ba3ad3caea86e2f2d5e1683
+EBUILD 86Box-4.0.ebuild 1722 BLAKE2B ac17d931d437b02a0f4dfd7d56ced50c6fc81d33f0ad099964204fb4c3f62557ee735bc7182d2f89f06a6388eb7f7f0aca8adb06ec2a444c39be31d3b61b5763 SHA512 46c30bfdd94995c3590729e86b28be1b58465d5080c2c592efed0d9aadb124de760a6ee9f5e3cdd14b80d4c366115f41c2b304f7a879c64827619c1bd9bf1e1b
MISC metadata.xml 1162 BLAKE2B 3293da00bec68462e7488dca4d16aa1a6f1e49be1bfd49b8ee5546e247440b7390f78089cc74293b62d18dec7ee0db4a80ed2de2d12401a1b5ebec80275f5646 SHA512 e0d1f641a1b3e751655b1665d4df758cfc648de47770552ce78d136946c322da4a0140358575fd3ed9adbb87d83aa4b28a6c8eda0be375fde0cd77b0b5718c9b