summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-20 01:00:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-20 01:00:14 +0000
commitf4106f0cb3d17dc4c85cd4d45816e2c18a8d29e2 (patch)
tree30f32cdcaa065cf7695f6f848d3fa7bfa998619a /app-emacs
parent8cb1b7629fb6936b7008bd364b5e4ec3ecf6f6cd (diff)
gentoo auto-resync : 20:03:2024 - 01:00:13
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin75171 -> 75335 bytes
-rw-r--r--app-emacs/scala-ts-mode/Manifest4
-rw-r--r--app-emacs/scala-ts-mode/files/50scala-ts-mode-gentoo.el2
-rw-r--r--app-emacs/scala-ts-mode/metadata.xml11
-rw-r--r--app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild33
5 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 9c3f12b011ef..b0f2b3d44438 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/scala-ts-mode/Manifest b/app-emacs/scala-ts-mode/Manifest
new file mode 100644
index 000000000000..3e1f2c636670
--- /dev/null
+++ b/app-emacs/scala-ts-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50scala-ts-mode-gentoo.el 88 BLAKE2B 56f20edbef0b7781b1b1646d1f286bcf6b3e1fdfb639e36c76c58d47e2af2481e721cb1e0ef67d0d8697f77b087285cddc32fd4bcfa2389dcd901cd90c88d4b8 SHA512 fdef05bdacc93e00506c50c1dd9c34f69497f7c6fdac7a393349b6b7937f3e727c48a38501949e74d72b93fbede07753f8e8b02363c5d7d311a49cf50d9bc5f2
+DIST scala-ts-mode-1.0.0_p20240316.tar.gz 18330 BLAKE2B aedcfa91563421673435def9dc2679d5c9f1feb1dde6214e8e7650ca8d72e6165253140bc506ba67cbc00b4e54d9edbb34db47089438b6de2e42699bf15ebfa7 SHA512 544622840cfefbab79ddae06d48cc5a9a6fb1802fd18f7c2b425b921713392e6d84b287dcdb3fa65d08d59f5af28ec2b23711685764affaf854238d3583b0cd3
+EBUILD scala-ts-mode-1.0.0_p20240316.ebuild 660 BLAKE2B 30196f2ea1f87134c2b37fb48c509a94c9a00f478cd9e42dc10926d060e3e6649d31d1c6c8a3e292d7bdca501fc8e3789f66a106eea9e4f79b8df0a52e106679 SHA512 e49e909ef09da37ff839847a10d5378de0e7ec67566249b9b179c36c89e6fe26bf1520f18d115b2161de31870fae6f8f5acbe75e6cfbe2266299139bf8cd5398
+MISC metadata.xml 337 BLAKE2B 004893fd44aa0ecde6aa9644e06ef557599238b3d32f2959858d419837100265f0d656d4fc5ded3bbaeea7d2fc4254ede11abd6a82cd1ebcabd0bcbcef0bb3d9 SHA512 37e139991287377910d515dcbd808030775a95d5716a8ef459dc537434b9746fa757ff6bf0177903a325944b8837da73ee924fb44f64138a8ebc1cf32541c64c
diff --git a/app-emacs/scala-ts-mode/files/50scala-ts-mode-gentoo.el b/app-emacs/scala-ts-mode/files/50scala-ts-mode-gentoo.el
new file mode 100644
index 000000000000..47898c79b2cb
--- /dev/null
+++ b/app-emacs/scala-ts-mode/files/50scala-ts-mode-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/scala-ts-mode-autoloads" nil t)
diff --git a/app-emacs/scala-ts-mode/metadata.xml b/app-emacs/scala-ts-mode/metadata.xml
new file mode 100644
index 000000000000..7e270e83dac9
--- /dev/null
+++ b/app-emacs/scala-ts-mode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">KaranAhlawat/scala-ts-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild b/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild
new file mode 100644
index 000000000000..8c3deff90084
--- /dev/null
+++ b/app-emacs/scala-ts-mode/scala-ts-mode-1.0.0_p20240316.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_COMMIT="11a01d726ac4fafb8a6688459ac79b41333bd6c8"
+DESCRIPTION="Emacs Scala Mode via Tree-Sitter"
+HOMEPAGE="https://github.com/KaranAhlawat/scala-ts-mode"
+SRC_URI="
+ https://codeload.github.com/KaranAhlawat/scala-ts-mode/tar.gz/${MY_COMMIT}
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-editors/emacs-29[tree-sitter]
+ dev-libs/tree-sitter-scala
+"
+
+DOCS="README.org"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}