summaryrefslogtreecommitdiff
path: root/app-emacs/zenirc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/zenirc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/zenirc')
-rw-r--r--app-emacs/zenirc/Manifest4
-rw-r--r--app-emacs/zenirc/files/50zenirc-gentoo.el2
-rw-r--r--app-emacs/zenirc/metadata.xml19
-rw-r--r--app-emacs/zenirc/zenirc-2.112-r1.ebuild42
4 files changed, 67 insertions, 0 deletions
diff --git a/app-emacs/zenirc/Manifest b/app-emacs/zenirc/Manifest
new file mode 100644
index 000000000000..85e3a233712c
--- /dev/null
+++ b/app-emacs/zenirc/Manifest
@@ -0,0 +1,4 @@
+AUX 50zenirc-gentoo.el 84 BLAKE2B b6c0ff344013d495be96fe6ef7facea0b844a4a122cf17479e5b881fa7da200da8a962d5a55ba948eea91a6e5c80ccaf8d6ae1a9f0864b9bc9ede6e95bd953fa SHA512 0f213ff273bbbfa60742b5a6a47b0df94d8b87e77307e209038fb1df65f25de3436ec53fa46dba4ed7c97457a38509715893dd4d8078d332640a008ce30a02e1
+DIST zenirc-2.112.tar.gz 270951 BLAKE2B 38c57a4e4957c9f1d95f5118d4e7f076c581f7dcbe04df70a1c5cac93cb7b44bbdfe390765921ef61c9899a8f66bd6fc8393317e275dc2e55054712d759abec2 SHA512 3859eb21ad80c8a32e473a272bf2b024039a7a5e4c87a168a71ee2d045f678397daebdce81358be3a50a0dae63c7f8f417600f0964250fdb505def2803a13fac
+EBUILD zenirc-2.112-r1.ebuild 995 BLAKE2B e88cda633c24dde18113c13347bbabdfe675283f2e6fc30425737e3ec836051d14cd53211552cd7be4a9d9479f13342017021cd22b9bbe7c1d4adea2a17ca804 SHA512 f9944cd0ca2c8a6880138b2cdfd3a3fb88d80445b2d6c62a6c5816f97caaa36059fb339e1b183efbd75644617b75b0d3448a87ce2a1aecebe62072dd6e63cbee
+MISC metadata.xml 904 BLAKE2B 33d313b140bc00f877481f34452ca6901500545f71ca53e0f9752b30c374f80c6133f0d4c2fa2ad89d676b769a997c616a691b3e6e8b020afaf57540e20cccce SHA512 13b6f7292ba8f28a447eae09b5122115e677f57b8d0fff36c9b2cbabf97cd9e46b456f6a7bb298b6aa8b3e6b9318003bd4f8af83344c3e960bd51c98b4da2800
diff --git a/app-emacs/zenirc/files/50zenirc-gentoo.el b/app-emacs/zenirc/files/50zenirc-gentoo.el
new file mode 100644
index 000000000000..c52c190d214a
--- /dev/null
+++ b/app-emacs/zenirc/files/50zenirc-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'zenirc "zenirc" "Start ZenIRC" t)
diff --git a/app-emacs/zenirc/metadata.xml b/app-emacs/zenirc/metadata.xml
new file mode 100644
index 000000000000..b17b9e2e6d34
--- /dev/null
+++ b/app-emacs/zenirc/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ ZenIRC is a full-featured scriptable IRC client for the EMACS text editor.
+ It runs on any OS where EMACS supports sockets. It is compatible with GNU
+ Emacs 18.59 and above, and all versions of XEmacs. ZenIRC is Free Software.
+ ZenIRC supports multiple irc sessions in separate buffers. There is a
+ rudimentary command syntax for use within those sessions, but most user
+ preferences and extensions are written and configured in emacs-lisp. Most
+ features are implemented via module extensions. For example, DCC (Direct
+ Client-to-Client) can be enabled at the user's option.
+</longdescription>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/zenirc/zenirc-2.112-r1.ebuild b/app-emacs/zenirc/zenirc-2.112-r1.ebuild
new file mode 100644
index 000000000000..b0c761c87450
--- /dev/null
+++ b/app-emacs/zenirc/zenirc-2.112-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="A full-featured scriptable IRC client for the Emacs text editor"
+HOMEPAGE="http://www.zenirc.org/"
+SRC_URI="ftp://ftp.zenirc.org/pub/zenirc/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ # econf won't work because of unknown options
+ ./configure --prefix="${EPREFIX}/usr/" || die "configure failed"
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ elisp-install ${PN} src/*.el src/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ doinfo doc/zenirc.info
+ dodoc BUGS INSTALL NEWS README TODO
+
+ cd doc
+ docinto doc
+ dodoc 666.conspiracy FAQ README-OLD ctcp.doc irc-operators \
+ server-list tao-of-irc tour.of.irc undernet
+
+ DOC_CONTENTS="Refer to the Info documentation and
+ ${SITELISP}/${PN}/zenirc-example.el for customization hints."
+ readme.gentoo_create_doc
+}