summaryrefslogtreecommitdiff
path: root/app-emacs/zenburn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/zenburn
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/zenburn')
-rw-r--r--app-emacs/zenburn/Manifest4
-rw-r--r--app-emacs/zenburn/files/50zenburn-gentoo.el4
-rw-r--r--app-emacs/zenburn/metadata.xml16
-rw-r--r--app-emacs/zenburn/zenburn-20110907.ebuild28
4 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/zenburn/Manifest b/app-emacs/zenburn/Manifest
new file mode 100644
index 000000000000..223244062895
--- /dev/null
+++ b/app-emacs/zenburn/Manifest
@@ -0,0 +1,4 @@
+AUX 50zenburn-gentoo.el 180 BLAKE2B 9ddd4068d000d8aec01e864f90c4ab1f418d45b4bd04c65ebdd3159e93dc6a2cf63dd1a11c88aa65a571dc1b89fc5e474ce6515f4b8f25392a870ec3961ccff5 SHA512 712853121e485d5100b89c69de853e8c0437c7b4c8fc47068281f6bc7dc3934a8417bb7e50f06b814991a016e6bb0be4859f01f63d4159523fb0ebc0acfbab23
+DIST zenburn-20110907.el.bz2 6979 BLAKE2B 3f38e857c9e09d73d5aafc7e5a98292c122b5ab903c902fe43be1d91ab20a9703a974707354b9f07eab190324ee4ac8a392efae06f2c05a07dd9914a78ebde4c SHA512 552f4a751ffadaf2f4174c7f722abc1fb7a8f84934df01f61c2d7cf653328ce8fd18473f0748eaa570ab9221544e5e9c81243e731a2fff5f2c9028b992163062
+EBUILD zenburn-20110907.ebuild 614 BLAKE2B 60a98f4d9c3301f50ef849bc4cb7b8f54b37bfd1e552c34a1e3b0ef783a5797a1f24039539ba46d122a03b83966285de99592c74a196adb8b94c36a387cbb929 SHA512 5fa53e44441c3f8ebd2ce3d6288b1f9191c6b2fc69caf81b816cf7f15dcfc8c0e215717939119a2273b2c4d670da6099a4f98d900e5c9ce5e06916992f5b76cf
+MISC metadata.xml 534 BLAKE2B d7a3d1d169842f90c9ce6ccc7b835c154f171098a8994f4769c041877c8d746915f461b2f97f651a62e4c750fb80290ce0549de9ccc6724c3e6fde9a5daf8947 SHA512 b1f6d9b271628e63c77f095228095581c7174207d6f1b24bac7c3b5de5ae7429b53621056a671e481dacaeba003f37e5911db3c47633ef3d80f64526214e4342
diff --git a/app-emacs/zenburn/files/50zenburn-gentoo.el b/app-emacs/zenburn/files/50zenburn-gentoo.el
new file mode 100644
index 000000000000..0844532b5014
--- /dev/null
+++ b/app-emacs/zenburn/files/50zenburn-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'color-theme-zenburn "zenburn"
+ "Just some alien fruit salad to keep you in the zone." t)
+(defalias 'zenburn 'color-theme-zenburn)
diff --git a/app-emacs/zenburn/metadata.xml b/app-emacs/zenburn/metadata.xml
new file mode 100644
index 000000000000..4e6bfa9db969
--- /dev/null
+++ b/app-emacs/zenburn/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ Zenburn is a low-contrast color theme. It's easy for your eyes and
+ designed to keep you in the zone for long programming sessions.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">dbrock/zenburn-el</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/zenburn/zenburn-20110907.ebuild b/app-emacs/zenburn/zenburn-20110907.ebuild
new file mode 100644
index 000000000000..71a6086ef93b
--- /dev/null
+++ b/app-emacs/zenburn/zenburn-20110907.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Zenburn color theme for Emacs"
+HOMEPAGE="http://slinky.imukuppi.org/zenburnpage/
+ https://github.com/dbrock/zenburn-el"
+# snapshot from upstream git repo
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-emacs/color-theme"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "To enable zenburn by default, initialise it in your ~/.emacs:"
+ elog " (color-theme-zenburn)"
+}