summaryrefslogtreecommitdiff
path: root/app-emacs/yasnippet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /app-emacs/yasnippet
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'app-emacs/yasnippet')
-rw-r--r--app-emacs/yasnippet/Manifest2
-rw-r--r--app-emacs/yasnippet/yasnippet-0.14.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/yasnippet/Manifest b/app-emacs/yasnippet/Manifest
index 44e31da55123..8890d0c765ed 100644
--- a/app-emacs/yasnippet/Manifest
+++ b/app-emacs/yasnippet/Manifest
@@ -1,4 +1,6 @@
AUX 50yasnippet-gentoo-0.13.0.el 221 BLAKE2B 51f86d04a825b5e1cb60019bddac2b0e2d91d735ffafdae497c87413eb0ad88efd969575edfe139ba250d2e2115f1c5a242de61f54031b684f35437e6e868989 SHA512 ace64b43229ee327add5d6ac056b86f7468ffb79569ca55d3692c93fd4b9e847d83fa731c8e54ad2aced5d64ed73c9cfa1fc6d6f9a883356dbb6a39142d9a2fb
DIST yasnippet-0.13.0.tar.gz 577330 BLAKE2B 21830c0a2e99d7669093c16f527debb4921e96aad006887ec1c7e35da58745721658417f1aec96ea78ba4dc5f3951c857848fce67e6d2ff7f255d4aea5687ab9 SHA512 73b111f72e98c4183764cef08ddfaa861dba49f171f96026b074bf62a7aa5e2d8529f616805ba386dd4157b675da953784d5bcd832d6015ce1b72e9c240988c5
+DIST yasnippet-0.14.0.tar.gz 581053 BLAKE2B efae02939d0174724803819fb9a47a414acad3b1d58da91d4f35c42c02282db9773f4f3caa020d01c2d87de741d3c60b39e1406b6ff7b3e5310ed4efc477d635 SHA512 c7f704187b3c700f8ea9e0205941d7a32602b6994307007cb83aa984ccf7e7e37be9589277a56c294703eab82ee4b1dffae7040f2e175e7d56cda5ef3c70eb39
EBUILD yasnippet-0.13.0.ebuild 1014 BLAKE2B 37db6268c4d6d08820e368c26fc6e488f50da201740e03acdb1aab3885de6163dd0d827dbb70d55ff8baf77ec030ca318f44db111ef862a66d1e5555c01174bb SHA512 64122bd778495c2c8114dffba65a1f556e18594679270996759c6edaff19662711e2482152b0cb8c4d658046aa601fb93115b32b884dc2931e1becb0e23da244
+EBUILD yasnippet-0.14.0.ebuild 1022 BLAKE2B 3df524906b793fcc0100d6b48acf7c86dad71db9dcd8ca31a461d1146af72b17b4c45b425676166b8452a649fafe6406510b1f3b90425f1b9909a7062ab0e92e SHA512 9c480537944c21bdced0eb4b88f288fffa039d0445519facd7ac2c22adf9cec846aca9fe240e256518593a94e4cf9d65817e91244fc93f274280de6de1ef18f3
MISC metadata.xml 520 BLAKE2B 2c5dbc7b7bedf1a900acbb8a48b07787857479210f3ea504a30119ee2669039ad00ddbdd09712dcb21cd99ed7db62ba4f81d901effe5442148ea40e0cb2c9220 SHA512 0c738db961c5deaffbae27974d89fccae4002c1209316b0ad1f9140a4959de9911edacab324b02f3bbec70db235da3454f08d43a7d8a4c13d955a99aff27487b
diff --git a/app-emacs/yasnippet/yasnippet-0.14.0.ebuild b/app-emacs/yasnippet/yasnippet-0.14.0.ebuild
new file mode 100644
index 000000000000..7e8fc0b1160b
--- /dev/null
+++ b/app-emacs/yasnippet/yasnippet-0.14.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Yet another snippet extension for Emacs"
+HOMEPAGE="http://joaotavora.github.com/yasnippet/"
+SRC_URI="https://github.com/joaotavora/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+SITEFILE="50${PN}-gentoo-0.13.0.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l yasnippet-tests \
+ -f ert-run-tests-batch-and-exit
+}
+
+src_install() {
+ elisp-install ${PN} yasnippet.{el,elc} yasnippet-debug.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc CONTRIBUTING.md NEWS README.mdown
+ use doc && dodoc -r doc/*
+
+ local DOC_CONTENTS="Add the following to your ~/.emacs to use YASnippet:
+ \n\t(require 'yasnippet)
+ \n\t(yas-global-mode 1)
+ \n\nYASnippet no longer bundles snippets directly. Install the package
+ app-emacs/yasnippet-snippets for a collection of snippets."
+ readme.gentoo_create_doc
+}