summaryrefslogtreecommitdiff
path: root/app-emacs/yasnippet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/yasnippet
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/yasnippet')
-rw-r--r--app-emacs/yasnippet/Manifest4
-rw-r--r--app-emacs/yasnippet/files/50yasnippet-gentoo-0.13.0.el4
-rw-r--r--app-emacs/yasnippet/metadata.xml16
-rw-r--r--app-emacs/yasnippet/yasnippet-0.13.0.ebuild36
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/yasnippet/Manifest b/app-emacs/yasnippet/Manifest
new file mode 100644
index 000000000000..cf18862df683
--- /dev/null
+++ b/app-emacs/yasnippet/Manifest
@@ -0,0 +1,4 @@
+AUX 50yasnippet-gentoo-0.13.0.el 221 BLAKE2B 51f86d04a825b5e1cb60019bddac2b0e2d91d735ffafdae497c87413eb0ad88efd969575edfe139ba250d2e2115f1c5a242de61f54031b684f35437e6e868989 SHA512 ace64b43229ee327add5d6ac056b86f7468ffb79569ca55d3692c93fd4b9e847d83fa731c8e54ad2aced5d64ed73c9cfa1fc6d6f9a883356dbb6a39142d9a2fb
+DIST yasnippet-0.13.0.tar.gz 577330 BLAKE2B 21830c0a2e99d7669093c16f527debb4921e96aad006887ec1c7e35da58745721658417f1aec96ea78ba4dc5f3951c857848fce67e6d2ff7f255d4aea5687ab9 SHA512 73b111f72e98c4183764cef08ddfaa861dba49f171f96026b074bf62a7aa5e2d8529f616805ba386dd4157b675da953784d5bcd832d6015ce1b72e9c240988c5
+EBUILD yasnippet-0.13.0.ebuild 1014 BLAKE2B 37db6268c4d6d08820e368c26fc6e488f50da201740e03acdb1aab3885de6163dd0d827dbb70d55ff8baf77ec030ca318f44db111ef862a66d1e5555c01174bb SHA512 64122bd778495c2c8114dffba65a1f556e18594679270996759c6edaff19662711e2482152b0cb8c4d658046aa601fb93115b32b884dc2931e1becb0e23da244
+MISC metadata.xml 519 BLAKE2B ee75758a0efbdb9bba9ade444a083901bd22dff47f20ace413983e446f0857b59ca1dbe9ae37dfb9e8ac9d3135ccdfc56dcab712d419a6946084b970ad673745 SHA512 cec1174ce420c4040c18719881f4bcba872af9a12d30ec3ba2e937374be62583a3a2e40622659e3823b2e0c81ba37fb8188fb58dbb0c09375a082eca20ae1421
diff --git a/app-emacs/yasnippet/files/50yasnippet-gentoo-0.13.0.el b/app-emacs/yasnippet/files/50yasnippet-gentoo-0.13.0.el
new file mode 100644
index 000000000000..e58ee2b29cf3
--- /dev/null
+++ b/app-emacs/yasnippet/files/50yasnippet-gentoo-0.13.0.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'yas-minor-mode "yasnippet" "Toggle YASnippet mode." t)
+(autoload 'yas-global-mode "yasnippet" nil t)
+(autoload 'snippet-mode "yasnippet" "A mode for editing yasnippets" t)
diff --git a/app-emacs/yasnippet/metadata.xml b/app-emacs/yasnippet/metadata.xml
new file mode 100644
index 000000000000..b284b51b5b48
--- /dev/null
+++ b/app-emacs/yasnippet/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ YASnippet is a re-design and re-write of smart-snippet. It is much
+ cleaner and more powerful than smart-snippet.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">joaotavora/yasnippet</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/yasnippet/yasnippet-0.13.0.ebuild b/app-emacs/yasnippet/yasnippet-0.13.0.ebuild
new file mode 100644
index 000000000000..e6ba47b23dc4
--- /dev/null
+++ b/app-emacs/yasnippet/yasnippet-0.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Yet another snippet extension for Emacs"
+HOMEPAGE="http://joaotavora.github.com/yasnippet/"
+SRC_URI="https://github.com/joaotavora/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+SITEFILE="50${PN}-gentoo-${PV}.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l yasnippet-tests \
+ -f ert-run-tests-batch-and-exit
+}
+
+src_install() {
+ elisp-install ${PN} yasnippet.el{,c} yasnippet-debug.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc CONTRIBUTING.md NEWS README.mdown
+ use doc && dodoc -r doc/*
+
+ DOC_CONTENTS="Add the following to your ~/.emacs to use YASnippet:
+ \n\t(require 'yasnippet)
+ \n\t(yas-global-mode 1)
+ \n\nYASnippet no longer bundles snippets directly. Install the package
+ app-emacs/yasnippet-snippets for a collection of snippets."
+ readme.gentoo_create_doc
+}