summaryrefslogtreecommitdiff
path: root/app-emacs/with-simulated-input
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emacs/with-simulated-input
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emacs/with-simulated-input')
-rw-r--r--app-emacs/with-simulated-input/Manifest4
-rw-r--r--app-emacs/with-simulated-input/files/50with-simulated-input-gentoo.el1
-rw-r--r--app-emacs/with-simulated-input/metadata.xml21
-rw-r--r--app-emacs/with-simulated-input/with-simulated-input-3.0.ebuild29
4 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/with-simulated-input/Manifest b/app-emacs/with-simulated-input/Manifest
new file mode 100644
index 000000000000..0d69459ffed2
--- /dev/null
+++ b/app-emacs/with-simulated-input/Manifest
@@ -0,0 +1,4 @@
+AUX 50with-simulated-input-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST with-simulated-input-3.0.tar.gz 26203 BLAKE2B 2629f28449a71828f67209b84123ee11b9eb838884560836129830f1c6e0dc12e95ba56e806de5eae8b29cbe1b3f199f9a9e292a2f048483b61a64aa138d2848 SHA512 ddb916e51e8f1da76a19a440f0a629ece6e27969be38b70d8b5156ab7c41084ef9a099970e2c74a680e0cdf75463698e60336fcd168f82d62acd1e0994d6897a
+EBUILD with-simulated-input-3.0.ebuild 702 BLAKE2B 1a1c1c4dfdb00f179a5f84229d03286233451e72f0559378e9badcc9b1437d296ee5609c3184ec829c7174a72197d98362ca3a4557f7ef8a51567e14faf74d8e SHA512 f36d91e655bcf8fc437e74ebda412e0dcab0f0b3b986553d097f2bc15fbd35f5ab5a380bf52dcca120da7f5bf06037f23bd5a8e8ce20229f2bc2668d829cea5d
+MISC metadata.xml 920 BLAKE2B 6b853bc4e2ec4ed5e5f89b915ae6bb27d361d7ac7f27debf77434840c6b53e9b68cb082ed9c341a6fa2b05972ff7e71d48c64d12e28feb7bd9e670aae06e7a45 SHA512 30355b0212aae9adfa1e9d887431915704040dbd42135595fb4267d1c8267ad88646cef7776fca439aba9d811ffebc2d84affb728d8a8b54cb7d4817f760e65a
diff --git a/app-emacs/with-simulated-input/files/50with-simulated-input-gentoo.el b/app-emacs/with-simulated-input/files/50with-simulated-input-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/with-simulated-input/files/50with-simulated-input-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/with-simulated-input/metadata.xml b/app-emacs/with-simulated-input/metadata.xml
new file mode 100644
index 000000000000..64bd70a80275
--- /dev/null
+++ b/app-emacs/with-simulated-input/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/DarwinAwardWinner/with-simulated-input/issues/</bugs-to>
+ <remote-id type="github">DarwinAwardWinner/with-simulated-input</remote-id>
+ </upstream>
+ <longdescription>
+ This package provides an Emacs Lisp macro, with-simulated-input, which
+ evaluates one or more forms while simulating a sequence of input events for
+ those forms to read. The result is the same as if you had evaluated the
+ forms and then manually typed in the same input. This macro is useful for
+ non-interactive testing of normally interactive commands and functions,
+ such as completing-read.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emacs/with-simulated-input/with-simulated-input-3.0.ebuild b/app-emacs/with-simulated-input/with-simulated-input-3.0.ebuild
new file mode 100644
index 000000000000..33361e6ac49a
--- /dev/null
+++ b/app-emacs/with-simulated-input/with-simulated-input-3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp macro to simulate user input non-interactively"
+HOMEPAGE="https://github.com/DarwinAwardWinner/with-simulated-input/"
+SRC_URI="https://github.com/DarwinAwardWinner/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/buttercup )"
+
+DOCS=( README.md )
+ELISP_REMOVE="tests/test-${PN}.el" # Remove failing tests; 11/49 specs
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ buttercup -L . -L tests --traceback full tests || die
+}