summaryrefslogtreecommitdiff
path: root/app-emacs/with-editor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-26 21:58:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-26 21:58:12 +0100
commitd76b6613e545057331e9273ddd21e68d28d9e402 (patch)
tree2823b704acff0caa2bf185b4e4b38c95731cba39 /app-emacs/with-editor
parentf6fd15e0418aea97c7ee77672468561cdac302e5 (diff)
gentoo auto-resync : 26:08:2023 - 21:58:11
Diffstat (limited to 'app-emacs/with-editor')
-rw-r--r--app-emacs/with-editor/Manifest2
-rw-r--r--app-emacs/with-editor/with-editor-3.3.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/with-editor/Manifest b/app-emacs/with-editor/Manifest
index e31ece183217..d440384f539b 100644
--- a/app-emacs/with-editor/Manifest
+++ b/app-emacs/with-editor/Manifest
@@ -1,4 +1,6 @@
DIST with-editor-3.3.0.tar.gz 33250 BLAKE2B 6dab10a489c2592a32091e708c7f4c7e4c80794569e0fdcef14407cc83e067ace4a2efb29c97ecf40e1d0f5f2557f7ecc78992e1a65e10ed1c39e812431ff0bc SHA512 1e703f0793068f4080ab9af553a682ffb8897d95d0fc61668773c9ff380a0ba966e6f458f2428269c4c113c8ec296472b15a3459dad7f01549fc3387a080fda0
+DIST with-editor-3.3.1.tar.gz 33258 BLAKE2B 9de704d2d8bf8dc2ab444d4205c21ef710cace84c670d4d84a29f0403f4424e5310049959df4f63a79e64480671a8605a497e71cfee2dc12f4f42c65656a234d SHA512 861659f0dbd696ced43e6d6ff903096bc83fb6f3bb911db11985e47b215f5c00659a454250c618c65140a3c8058011746b3f7a1b8c25f6641368864aa196b77f
EBUILD with-editor-3.3.0.ebuild 677 BLAKE2B 9a04e7579eb72bf8272fe7c54fbe1f5b13b11f95f96e147dfd2ee294ab81fa3ab324ab73502fbca06113e8ca37a9195208e59b6790a971aa25eccab4730e8b4e SHA512 3697fbeb70cf65aa918d918f5c6a6f1e7f52d0c1d869e1fb8e8b69c13b9380d51506ac21debdd1e2c0cde202d110525151284c42f15bbd671c0acd476c5186df
+EBUILD with-editor-3.3.1.ebuild 680 BLAKE2B 24457974784dfe2347402406db530c5d41928005e006878e4b3631a6b9d5889d8073f11e9c436bc6566b6f9a8a9fc11dd36298b1dc87f5c50013febd4e06749e SHA512 6027ce05976621329b04e9f63ed367b295ca43a00d0104fb716413c70f7f33705b4e4a9d5f3a491fd7b6b218af2f1eec5a2050fa736d553dc551fcd94fdc1f30
EBUILD with-editor-9999.ebuild 786 BLAKE2B 7deae1a9cd43920b083a74caaff3e3ade75151df1483cc6c64683843d85901fc23753ae8c0b3e539e52c36f95bf268d4d04b895b5fd776b18ea5d5fc99b0690b SHA512 37e79a8b4af42d1b8bd158ba3d9a3cfcdbe456d334d3561638ba8786bd6137d48e3317e0fae1729c1fa0847beec723cce1c6940712f20cbc0ed571cc30354a42
MISC metadata.xml 708 BLAKE2B f2e619818ede95a7a0b17cc7f36f903f4210ddc634d4f0edf27886e8fbc4d084daa5ef67c8167ef2f39930141c8dbe1e98c4e5992b7af35234499fa73e9de4cc SHA512 bf422e1a42e025426795319834a7fa75252e8f2c42da1d82098e2def918ed9c4f827978753c86cc4e41cde581bcdc8eb2c9781d75849a80ab6f94f945b4cdea3
diff --git a/app-emacs/with-editor/with-editor-3.3.1.ebuild b/app-emacs/with-editor/with-editor-3.3.1.ebuild
new file mode 100644
index 000000000000..fd92a8464661
--- /dev/null
+++ b/app-emacs/with-editor/with-editor-3.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/with-editor/
+ https://github.com/magit/with-editor/"
+SRC_URI="https://github.com/magit/with-editor/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/lisp
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.1
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+DOCS=( ../README.org ../docs/${PN}.org )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"