summaryrefslogtreecommitdiff
path: root/app-emacs/windows
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/windows
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/windows')
-rw-r--r--app-emacs/windows/Manifest4
-rw-r--r--app-emacs/windows/files/50windows-gentoo.el2
-rw-r--r--app-emacs/windows/metadata.xml9
-rw-r--r--app-emacs/windows/windows-2.49.ebuild25
4 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/windows/Manifest b/app-emacs/windows/Manifest
new file mode 100644
index 000000000000..20ea42477652
--- /dev/null
+++ b/app-emacs/windows/Manifest
@@ -0,0 +1,4 @@
+AUX 50windows-gentoo.el 71 BLAKE2B b0bdccf744fea902944facc65fc45d69a1b67c0a7517514731cad427be77d09c7a3263634e91a887dc4cd7344e15cefb794f7da2403b9fd8778d4f8594dae760 SHA512 9ee731d8d54d7808903fea39ca70fee4d9216f6980f02b8511b6d643040335acfdad2a9336d9c8baa9babf0805f9eef5ace760cd0e965c6c964a2bd7599e5d6d
+DIST windows-2.49.el.xz 26240 BLAKE2B 161003a6b995b84df79eb0459ddfce41049ffcd053cacb2d5ceefda89afae0eb82f382b7f60b267846bd8690f406a5fcea166c6e602378729140f8e951977265 SHA512 de75f2c07cd544de7e7c616b5b928c0dd538b341396819a49525304ed3d9c01c4814e0f8a8da97bdf1a449844605127da690db3ccd95980240156d3c3600b704
+EBUILD windows-2.49.ebuild 543 BLAKE2B 8598f19c18b66fedded09b7dad20b9f7b747fa9f65e5ae396ee0663d3596e779626235e1190a47355fd72288b1799bb6e06d9a166fd0d53ea89b07025c3beb37 SHA512 01e8aa63f4f4cf212737c906a11ed1cb7291c70f54cc8c432d1eef6bac694f7b81724645274ff35932592a264910d829719f8a11b904bffb4505773e56d86dbf
+MISC metadata.xml 292 BLAKE2B 046265ce3ff94f04bba9b4b344d852203657df8dd300f30620df260bad1c56b3c23a8c48d073f70f571f733af9a7c034922e0465878028ee8f748060a6816ec6 SHA512 f0115ae686d3003f4264968d3aeb0b054830f87f35378e15e205a729d591c8697507d3c76ead9e1f0bab1f1f66a3fda108322dbcec7b857a37000511d1dd17df
diff --git a/app-emacs/windows/files/50windows-gentoo.el b/app-emacs/windows/files/50windows-gentoo.el
new file mode 100644
index 000000000000..892a4208f52f
--- /dev/null
+++ b/app-emacs/windows/files/50windows-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "windows-autoloads" nil t)
diff --git a/app-emacs/windows/metadata.xml b/app-emacs/windows/metadata.xml
new file mode 100644
index 000000000000..c6a53b949e75
--- /dev/null
+++ b/app-emacs/windows/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/windows/windows-2.49.ebuild b/app-emacs/windows/windows-2.49.ebuild
new file mode 100644
index 000000000000..75cecc5d2318
--- /dev/null
+++ b/app-emacs/windows/windows-2.49.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Window manager for GNU Emacs"
+HOMEPAGE="http://www.gentei.org/~yuuji/software/"
+# taken from http://www.gentei.org/~yuuji/software/euc/windows.el
+SRC_URI="https://github.com/gavv/distfiles/raw/master/${P}.el.xz"
+
+LICENSE="yuuji"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-emacs/revive"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}