summaryrefslogtreecommitdiff
path: root/app-emacs/which-key
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/which-key
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/which-key')
-rw-r--r--app-emacs/which-key/Manifest4
-rw-r--r--app-emacs/which-key/files/50which-key-gentoo.el3
-rw-r--r--app-emacs/which-key/metadata.xml13
-rw-r--r--app-emacs/which-key/which-key-3.6.0.ebuild36
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/which-key/Manifest b/app-emacs/which-key/Manifest
new file mode 100644
index 000000000000..dacbea346606
--- /dev/null
+++ b/app-emacs/which-key/Manifest
@@ -0,0 +1,4 @@
+AUX 50which-key-gentoo.el 106 BLAKE2B 71254e87973b2d730eb3caad021a07c48681c71f93a2e909663143a95b934469fcd76c204aaa73ed3b9c1457caf9a3c29dcf459bce4aaa2cf3d412ea8be93ef2 SHA512 9cd7f95f75ed3a45c2084164d9bd1bc7e5a01d5153596e8840e6e725a4ba11110b6618cd039be7652b695907d357c1efebd5450f5821e44ca824fb6beb79855d
+DIST which-key-3.6.0.tar.gz 462441 BLAKE2B e56dacff2003192e769e53f728538246f4b3c2f00273022a81382e3afaf4c1b7016a2da468ade1e1f0b3b33df7352a327f75c43fef990c432bbb55f3aad7a934 SHA512 8ecfa3e5d0529cc0e879772d2ea2fcbbdfc8ab559dc8befddd63b91e6ed726baa6c0069bc0f30dc417eb288d02a281f1b07b5c966a361f390cab4d7392c2e56c
+EBUILD which-key-3.6.0.ebuild 916 BLAKE2B 0640a651eb4fd9787900502def0218172490543b03d9362be6902cb654ba75b3edb27831e9ec69987d052cb63f0b952c2aeb1830f991299d5644984e2c1411c8 SHA512 8568a8c377fac738c0d1519b5e9abb3a9190e07b4ce3efd93580ed7a8c2c0ead6004b7fe2468edaa5d7ff0f2e677a420ac839ed7c35f9cfdd7d23803ffc5d845
+MISC metadata.xml 435 BLAKE2B a9b9271949169684743f07fa04c907d33112498d1e258fd6093cfa85425146bb4c2e6e5f326ab4de76704bf294ee8402162855e98440052511ee0f0393fbb458 SHA512 66167f5d8a9c20b093005143d3aa2ddb50423cc2dbe933c644d4551ec4c4e914b7f773a0732ac7b930e87facadbce0e7c6435aac1c7b5982b38d58a41c75376a
diff --git a/app-emacs/which-key/files/50which-key-gentoo.el b/app-emacs/which-key/files/50which-key-gentoo.el
new file mode 100644
index 000000000000..d46c0735a841
--- /dev/null
+++ b/app-emacs/which-key/files/50which-key-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'which-key-mode "which-key"
+ "Toggle which-key-mode." t)
diff --git a/app-emacs/which-key/metadata.xml b/app-emacs/which-key/metadata.xml
new file mode 100644
index 000000000000..d1d749f4165a
--- /dev/null
+++ b/app-emacs/which-key/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/justbur/emacs-which-key/issues/</bugs-to>
+ <remote-id type="github">justbur/emacs-which-key</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/which-key/which-key-3.6.0.ebuild b/app-emacs/which-key/which-key-3.6.0.ebuild
new file mode 100644
index 000000000000..e5243f24d20c
--- /dev/null
+++ b/app-emacs/which-key/which-key-3.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Display the key bindings following your currently entered keys"
+HOMEPAGE="https://github.com/justbur/emacs-which-key/"
+SRC_URI="https://github.com/justbur/emacs-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org img )
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="To enable \"which-key-mode\" globally,
+ add the following to your init file:
+ \n\t(which-key-mode)"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} -l ${PN}.el -l ${PN}-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ einstalldocs
+ readme.gentoo_create_doc
+}