summaryrefslogtreecommitdiff
path: root/app-emacs/wgrep
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/wgrep
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/wgrep')
-rw-r--r--app-emacs/wgrep/Manifest4
-rw-r--r--app-emacs/wgrep/files/50wgrep-gentoo.el1
-rw-r--r--app-emacs/wgrep/metadata.xml16
-rw-r--r--app-emacs/wgrep/wgrep-2.1.10.ebuild19
4 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/wgrep/Manifest b/app-emacs/wgrep/Manifest
new file mode 100644
index 000000000000..5a8260bdbe0a
--- /dev/null
+++ b/app-emacs/wgrep/Manifest
@@ -0,0 +1,4 @@
+AUX 50wgrep-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST wgrep-2.1.10.el.xz 8708 BLAKE2B f3881a5b774dd9bad6169f5621d4da4662127892786e708d31815cba2ff2f5a75170863ca5882cef67efb8e27964cab4176eda7c7ca561888edeb590943ae573 SHA512 39761964406d3eedca9253f2f29f81dd9ee71c4e049a985c236ada4dd9b70dc553bf1e9e94cb6d3c8749f065146e2759a46a6ac52ed8e5e5f046e196798bc681
+EBUILD wgrep-2.1.10.ebuild 576 BLAKE2B dc5197bbdf21aa1a8ca259360fec8e41317b2fd646c7da96466de3f3db36bde8224556c837a7441c6617a82875bb3616a33abc9f9b2f26bfb366541e1297c1a8 SHA512 c39b7177e3bfe8e71fb079dbf41560214971d83f7526fff5760be3c080f4014b21a8b5b0abe7f09dea64b4130e0a617817923079b66ffea1b2f50ef1bab198fc
+MISC metadata.xml 493 BLAKE2B c8676488f610b89dab42bd037c33e1fe6af7861ad188c28e4703c7b18665102a4b2270a5c746929cad1ba11522be8e523b80712a929bc38d1ecef71b3a8b6ba3 SHA512 8af6e19dda9919614f6bb5e1dbde585fc0128d679c1ad0685eed2cd43d93e38686f1c88f1c86f0b6dfc5cc12cb7ce25c97fb4d2766d6e2cb33b1915dc9356763
diff --git a/app-emacs/wgrep/files/50wgrep-gentoo.el b/app-emacs/wgrep/files/50wgrep-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/wgrep/files/50wgrep-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/wgrep/metadata.xml b/app-emacs/wgrep/metadata.xml
new file mode 100644
index 000000000000..d76bc74d5053
--- /dev/null
+++ b/app-emacs/wgrep/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ wgrep allows you to edit a grep buffer and apply those changes to
+ the file buffer.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">mhayashi1120/Emacs-wgrep</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/wgrep/wgrep-2.1.10.ebuild b/app-emacs/wgrep/wgrep-2.1.10.ebuild
new file mode 100644
index 000000000000..69e3dc867b1a
--- /dev/null
+++ b/app-emacs/wgrep/wgrep-2.1.10.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Writable grep buffer and apply the changes to files"
+HOMEPAGE="https://github.com/mhayashi1120/Emacs-wgrep"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="See commentary in ${SITELISP}/${PN}/wgrep.el for documentation.
+ \n\nTo activate wgrep, add the following line to your ~/.emacs file:
+ \n\t(require 'wgrep)"