summaryrefslogtreecommitdiff
path: root/app-emacs/websocket/websocket-1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /app-emacs/websocket/websocket-1.10.ebuild
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'app-emacs/websocket/websocket-1.10.ebuild')
-rw-r--r--app-emacs/websocket/websocket-1.10.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/websocket/websocket-1.10.ebuild b/app-emacs/websocket/websocket-1.10.ebuild
new file mode 100644
index 000000000000..2211d645c5a3
--- /dev/null
+++ b/app-emacs/websocket/websocket-1.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A websocket implementation in elisp"
+HOMEPAGE="https://github.com/ahyatt/emacs-websocket"
+SRC_URI="https://github.com/ahyatt/emacs-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/emacs-${P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile websocket.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l websocket-test \
+ -f ert-run-tests-batch-and-exit
+}
+
+src_install() {
+ elisp-install ${PN} websocket.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README.org websocket-functional-test.el testserver.py
+}