summaryrefslogtreecommitdiff
path: root/app-emacs/w3mnav/w3mnav-0.5-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/w3mnav/w3mnav-0.5-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/w3mnav/w3mnav-0.5-r3.ebuild')
-rw-r--r--app-emacs/w3mnav/w3mnav-0.5-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/w3mnav/w3mnav-0.5-r3.ebuild b/app-emacs/w3mnav/w3mnav-0.5-r3.ebuild
new file mode 100644
index 000000000000..d79f39ef371f
--- /dev/null
+++ b/app-emacs/w3mnav/w3mnav-0.5-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Add Info-like navigation keys to the emacs-w3m web browser"
+HOMEPAGE="http://www.neilvandyke.org/w3mnav/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-emacs/emacs-w3m"
+RDEPEND="${DEPEND}"
+
+SITEFILE="75${PN}-gentoo.el"
+
+src_compile() {
+ ${EMACS} ${EMACSFLAGS} -L "${SITELISP}/emacs-w3m" \
+ -f batch-byte-compile w3mnav.el || die "byte-compile failed"
+}