summaryrefslogtreecommitdiff
path: root/app-emacs/vue-html-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
commiteb509e1a15f595f667e8d177ddb73311084af6c0 (patch)
treefbc083f793d438d54b7fb4ec3a7e0286701b81bb /app-emacs/vue-html-mode
parenteedf7b9dec39b69b43f7b581da418d37428db449 (diff)
gentoo auto-resync : 21:05:2023 - 20:55:01
Diffstat (limited to 'app-emacs/vue-html-mode')
-rw-r--r--app-emacs/vue-html-mode/Manifest4
-rw-r--r--app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el3
-rw-r--r--app-emacs/vue-html-mode/metadata.xml21
-rw-r--r--app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild24
4 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/vue-html-mode/Manifest b/app-emacs/vue-html-mode/Manifest
new file mode 100644
index 000000000000..8f93db77718d
--- /dev/null
+++ b/app-emacs/vue-html-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50vue-html-mode-gentoo.el 119 BLAKE2B d90f13954dc7478c279f74985906b30f49ed6cb2fd99b77c5ce06fef9fb01fd860f89d6e176186a57d2e109c7db8e94ce520a2085f5b09b31d7669c7891904b4 SHA512 098e37fe09325f9bf8dd06919e44a06c212efef58b24bfdaba20f3bebb7734a4ecac1fe18dd48615ccb6ece0852f221a1cab364a54ee2ef1f8fa3633b9158c1e
+DIST vue-html-mode-0.2.tar.gz 17744 BLAKE2B 460a6f67c00d3b2e7372209766c2dc1729ff5ac1ef9ca8951ac0677937130d5b54cb3c22702d304efe70aa57117af067b6a103197738efa1f5ee77f285e01c18 SHA512 8fe8f19059d64355af9ae2ac95aba2ac71b50153f5a3270fd75b70433bce3fa628a04abe03dea84671dabe5c604b7b0ae298b33214038ef9fa5dff8aaf418a56
+EBUILD vue-html-mode-0.2.ebuild 549 BLAKE2B 130ee0da8d350810da96f42ce87be79cd6919e53e15b9cba2431ba677a6fed4ac93f1b9a5f9f09eeb9ae5c6025ce3359399cdb141c02a066dd866db82daa0e98 SHA512 2ccacc7ea3d578e4d51532ad3f948773de1c62be5cbedbc92bb75be1b5b4258ed12e20f697da52628564f15436cbdf0f719794915a1ab7a886ee719ae679280c
+MISC metadata.xml 873 BLAKE2B c14c69cecd4dd6c84fa9e0a2c8fd70fb9a72faa26be5c027323dadf0e263f67709f7d27d5b6a6607dab9cc1ca976257235ca80edebb269467a017d8097b34909 SHA512 477bcafaa2067146959fd7fe58aaf64ebe7f08ded64a98a6f2c504bf36e66fd17c02578287d0f25c50930551ab1e7644ca1bd84000ab3460c03207244b8f1d8f
diff --git a/app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el b/app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el
new file mode 100644
index 000000000000..0bc482778051
--- /dev/null
+++ b/app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'vue-html-mode "vue-html-mode"
+ "Major mode for Vue.js templates." t)
diff --git a/app-emacs/vue-html-mode/metadata.xml b/app-emacs/vue-html-mode/metadata.xml
new file mode 100644
index 000000000000..d51da01a3b2d
--- /dev/null
+++ b/app-emacs/vue-html-mode/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ The main features of this mode are syntax highlighting (enabled with
+ font-lock-mode or global-font-lock-mode), and html-mode integration. Vue
+ component files are best edited with the excellent vue-mode, which the
+ author of this package also contributes to. This mode is included in
+ vue-mode, and is the default mode for editing template blocks.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/AdamNiederer/vue-html-mode/issues/</bugs-to>
+ <remote-id type="github">AdamNiederer/vue-html-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild b/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild
new file mode 100644
index 000000000000..420647bc0094
--- /dev/null
+++ b/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Major Emacs mode for editing Vue.js templates"
+HOMEPAGE="https://github.com/AdamNiederer/vue-html-mode/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AdamNiederer/${PN}.git"
+else
+ SRC_URI="https://github.com/AdamNiederer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"