summaryrefslogtreecommitdiff
path: root/app-emacs/vertico
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-03 10:05:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-03 10:05:34 +0100
commit0eb9883b5a8a53c253c98d1c77438c39c27c8c97 (patch)
tree47a89f252688f21fcacd066ac01ed1992a453d42 /app-emacs/vertico
parentc6872c361190d4f1a559d23458f6cdffb154b0b0 (diff)
gentoo auto-resync : 03:07:2023 - 10:05:34
Diffstat (limited to 'app-emacs/vertico')
-rw-r--r--app-emacs/vertico/Manifest3
-rw-r--r--app-emacs/vertico/vertico-1.4.ebuild14
-rw-r--r--app-emacs/vertico/vertico-9999.ebuild39
3 files changed, 51 insertions, 5 deletions
diff --git a/app-emacs/vertico/Manifest b/app-emacs/vertico/Manifest
index 6afe5aaccebd..dc65ecc63687 100644
--- a/app-emacs/vertico/Manifest
+++ b/app-emacs/vertico/Manifest
@@ -4,5 +4,6 @@ DIST vertico-1.3.tar.gz 45142 BLAKE2B a835e540ce271b5dc1cea13a9894a82c6adc6729cf
DIST vertico-1.4.tar.gz 45260 BLAKE2B 199472fd9126bdb940eeac811c19f4a9f8efe5c5a31ce580ab148db23bb69bb47c71ec9299339e768fd8662dd38fe39e469d4548cd8c15b761a1b282d5bcbf67 SHA512 2ff48178807e5bd32d8515bc3a1c435be191b1383ca749cdaca8e15140c86253b6b5073c883c080ded42f6ec511acd4292b1cce415a696911f5f932a0de167f3
EBUILD vertico-1.1.ebuild 609 BLAKE2B 6c72789cf6e818c6b8078ce43121834b96e7a6eb03f8adcad43c34b99c4412c01e8d81e7d78d392509abc4cbb0f276b993d085d4461360934b2ee4648340a096 SHA512 45b9af6bccfee6fcadae975a016267294d404c561c2e99821ee7c191bd8e579bd55d9fddb98dbf8df92b6238e557538b06112946013a663d2289aaa6af3b22bf
EBUILD vertico-1.3.ebuild 609 BLAKE2B ada962f38b7e311699066545405b0bd897ea716e55a316651e481b1d14759259e90b7ce5a374fee8b0d504cd5b0aeaf1c623997f0c6e7a90e8e7815199ed4f2f SHA512 fcfbbdfd803ff56cbcacc6bf6698675aa418ca4650c30a8c92cd7929b26ae65518cc0bf9a3b0ceb19784f1203b0940fe699aadcef3da58ebd504cd04d4a029c2
-EBUILD vertico-1.4.ebuild 609 BLAKE2B ada962f38b7e311699066545405b0bd897ea716e55a316651e481b1d14759259e90b7ce5a374fee8b0d504cd5b0aeaf1c623997f0c6e7a90e8e7815199ed4f2f SHA512 fcfbbdfd803ff56cbcacc6bf6698675aa418ca4650c30a8c92cd7929b26ae65518cc0bf9a3b0ceb19784f1203b0940fe699aadcef3da58ebd504cd04d4a029c2
+EBUILD vertico-1.4.ebuild 722 BLAKE2B d278c4960746e2c7f0879940e153456469274acdf8f79350f829068e3dc64b713ee14b8adb1da2f7c35a82d83bd23f360e0f94abaec647b956ddd9de172387d3 SHA512 641e37d4913e1d6e237dd182d816c6e40e32cd94deb626e66f22fa1db0164312f3589ff440fb807dcbbae0850752da1d27c45b5feedd2155ac6111520bd404d4
+EBUILD vertico-9999.ebuild 722 BLAKE2B d278c4960746e2c7f0879940e153456469274acdf8f79350f829068e3dc64b713ee14b8adb1da2f7c35a82d83bd23f360e0f94abaec647b956ddd9de172387d3 SHA512 641e37d4913e1d6e237dd182d816c6e40e32cd94deb626e66f22fa1db0164312f3589ff440fb807dcbbae0850752da1d27c45b5feedd2155ac6111520bd404d4
MISC metadata.xml 359 BLAKE2B d5d9e7f1c0ec1dc75d7fde73aa75f364f15740857e6a2bf39b3374424c3fcff4e79ceda481141598fee17c694b4c3538059f5bf95186aad6d535eacabcdb3341 SHA512 93e435f0f7bdb4d26a48525109688b964049a0b61d4b5633bd61dfd14ab68a5bd7e367d0cb7e45f5f1a57d73b8b63a9b2f8b0da9ac289bd4242da3b6f434b987
diff --git a/app-emacs/vertico/vertico-1.4.ebuild b/app-emacs/vertico/vertico-1.4.ebuild
index 0ff52c845500..8623d46e2c78 100644
--- a/app-emacs/vertico/vertico-1.4.ebuild
+++ b/app-emacs/vertico/vertico-1.4.ebuild
@@ -8,13 +8,19 @@ NEED_EMACS=27.1
inherit elisp
DESCRIPTION="Vertical interactive completion"
-HOMEPAGE="https://github.com/minad/vertico"
-SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/minad/vertico/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
RDEPEND=">=app-emacs/compat-29.1.4.0"
BDEPEND="${RDEPEND}"
diff --git a/app-emacs/vertico/vertico-9999.ebuild b/app-emacs/vertico/vertico-9999.ebuild
new file mode 100644
index 000000000000..8623d46e2c78
--- /dev/null
+++ b/app-emacs/vertico/vertico-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el ./ || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}