summaryrefslogtreecommitdiff
path: root/app-emacs/uboat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-17 10:00:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-17 10:00:35 +0100
commitcf89ca044e37f79e2329552cda857215f9824e11 (patch)
treea6720b1db82c94482ed8a998aa77650c5f723358 /app-emacs/uboat
parentcb627578a344c874750e23e7eb59b1acc85aa639 (diff)
gentoo auto-resync : 17:10:2023 - 10:00:35
Diffstat (limited to 'app-emacs/uboat')
-rw-r--r--app-emacs/uboat/Manifest2
-rw-r--r--app-emacs/uboat/files/uboat-1.2-iap.patch11
-rw-r--r--app-emacs/uboat/uboat-1.2-r1.ebuild18
3 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/uboat/Manifest b/app-emacs/uboat/Manifest
index c4e664cf34b9..de907263486f 100644
--- a/app-emacs/uboat/Manifest
+++ b/app-emacs/uboat/Manifest
@@ -1,4 +1,6 @@
AUX 50uboat-gentoo.el 84 BLAKE2B a4fa581b5fc4982886363b0c823b9ea497e1450666f5878104976b6ba82d7248685e7421601847a9d9929fdeb56d6febd9399a9b780d998887685d0136e5b3ce SHA512 fc349a5f8751437d03975fe2dd93c754ea29a164b626726f724e26b8bfd0f1c96098f471086443e46d95fa9fd4d06da12174305c0327fb06396362fa847a0574
+AUX uboat-1.2-iap.patch 365 BLAKE2B b73cc23f63b6f3ca3c11cefc30b45c21c0f48565a199973504843b4019737fb22d8c36e83433082548b8b626f3742698b30f82f7afe86585d638bfa95b1ad244 SHA512 da72547562a880f0969e483c88a424fba2342a9ce3665ec78a6ea867fb3fa1576767b350e5f1137e8e8cde5462fd1d091ab8eecd99c75a12289278f7fd7c6d81
DIST uboat-1.2.tar.bz2 1978 BLAKE2B c40c054863d5d13a415355144d216bb03e34205ba65853669758d8e2c44de34534a8460f1c5f6a4dd25543e9d2d0c2f3df5ec3b7146348b616ed2a88ca6b5cd6 SHA512 f77de2c0859a5eb8c09f03aea5be068e2f61f96e10c72d9f18ec6c3fdcc19ab7ca62d606d06aa669b07a89e9f677f5bcb6d3e211b7b7710840cacf9d4f3e307c
+EBUILD uboat-1.2-r1.ebuild 541 BLAKE2B 370610c294759bc22a112e948895380aecb3b8693d846e25bd3a4533f4cd7a34791999f8f40fda133e7f8bb3bc4a2c9d99dea4ac8585ab3395aefd7b62268482 SHA512 5c451cbf33aba3969fc31dac2e3a46c47d67ece67141f0b171db7e5358b7f08b1d437e334dad9d604f303f25a50e1825502e0d7dfa918008914099c0c6b31826
EBUILD uboat-1.2.ebuild 475 BLAKE2B 76ab210bec562d832205edd7ed8906fb7de62b436c864d91a400942a6899a91bcaa89aca1c12c33d96ecaa4ce8ce40646058a77b7569c78ae7a8994ee0939605 SHA512 f414ec68385762fb28c7d673aff16acbd8072172b327de0aea38fd23d59503e7e7c46296774ca47959016ef698b20b353ca1388848a067026459a0135b599911
MISC metadata.xml 283 BLAKE2B 81c49021199f71096079a27f9121390fb8c1285c54b9478583ff2d647277fa106ef12456d7097c4be092fc48b514a1adcf855ca0fac911598232ef9eb7f102c0 SHA512 f32b303760addf5d4db8d18bd10fb677353cdfa4c5e545d47804ef756cf5e5a21f8b8efb631b08f802185913ceb98da820e404e06eb03d01fe9ea85c10d1ac13
diff --git a/app-emacs/uboat/files/uboat-1.2-iap.patch b/app-emacs/uboat/files/uboat-1.2-iap.patch
new file mode 100644
index 000000000000..585b385a42e3
--- /dev/null
+++ b/app-emacs/uboat/files/uboat-1.2-iap.patch
@@ -0,0 +1,11 @@
+--- uboat-1.2/uboat.el
++++ uboat-1.2/uboat.el
+@@ -79,7 +79,7 @@
+ (let ((s (concat (uboat-iterate-list (uboat-random-member uboat-message)
+ "uboat-")
+ " U-" (int-to-string (random 999)) ".")))
+- (and (interactive-p)
++ (and (called-interactively-p 'interactive)
+ (message "%s" s))
+ s))
+
diff --git a/app-emacs/uboat/uboat-1.2-r1.ebuild b/app-emacs/uboat/uboat-1.2-r1.ebuild
new file mode 100644
index 000000000000..c440e10ac069
--- /dev/null
+++ b/app-emacs/uboat/uboat-1.2-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Generate u-boat-death messages, patterned after Iron Coffins"
+HOMEPAGE="http://www.splode.com/~friedman/software/emacs-lisp/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.bz2"
+
+# Noah Friedman and Bob Manson have confirmed that this is in the public domain
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}/${P}-iap.patch" )
+SITEFILE="50${PN}-gentoo.el"