summaryrefslogtreecommitdiff
path: root/app-emacs/typescript-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/typescript-mode
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/typescript-mode')
-rw-r--r--app-emacs/typescript-mode/Manifest4
-rw-r--r--app-emacs/typescript-mode/files/50typescript-mode-gentoo.el4
-rw-r--r--app-emacs/typescript-mode/metadata.xml13
-rw-r--r--app-emacs/typescript-mode/typescript-mode-0.4.ebuild35
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/typescript-mode/Manifest b/app-emacs/typescript-mode/Manifest
new file mode 100644
index 000000000000..ec5aadf2f7a2
--- /dev/null
+++ b/app-emacs/typescript-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50typescript-mode-gentoo.el 188 BLAKE2B 842bb64c905de119338975c0717c2ab4db5111644889c1da8d325f55efb67fd29c456d938718eb27e947e0d7c13cbb0ddb39c956099c09a24962e86349ceecda SHA512 2ffd54a6730c7f152a375227482720649865be1097a4f758152dab4b6f113eef5fa3acb9c6cf704db08f27dd85553ed6af2c1a4a25390042cd4e73b8146cb150
+DIST typescript-mode-0.4.tar.gz 65534 BLAKE2B b72047749cac571ad4a109b0d8650319137c2f75672882940092bff097e3a8c877b59cb51aa89b28a6cbeacfddbd6730e634a5a33305c006d401d326fd7f5704 SHA512 5bb38ab14fa9b022744b790e62740a95cee4ca906bab9eaaea8804cfae78c4ead54770d7e53d323ee57799bff5101cc10b7327105b7b0d0b17c74bda64203972
+EBUILD typescript-mode-0.4.ebuild 740 BLAKE2B bff624a7855cb62cde1310470b5a8d819975fbf967322b74afba2680d5a7eaad82d68257a020b6d181eca319fcac3eb62eded8b7a6ac715911628efb40531128 SHA512 35d9ef8ba5236475392d7d4840179a2d4075d46a7a1dac2a98fc2d170f8922364e86259ad6f455a7f442259cb9c787c7575244ba0c5e1197305321c095660368
+MISC metadata.xml 449 BLAKE2B ff09587f78cdef036ea37525c48ec09eff9192d5849256816440477652ea568594eca5e5505a3266ed0834ced527856a01d1093a996c334f657199c445966553 SHA512 6c7ce95e48733f316befb85f986b524b2fcda730ab82979c8dc2ee72c0bd7d58ad6992ce5fb76452375b946c1f502f29e997099064cc1dbce1c790ef872d97cc
diff --git a/app-emacs/typescript-mode/files/50typescript-mode-gentoo.el b/app-emacs/typescript-mode/files/50typescript-mode-gentoo.el
new file mode 100644
index 000000000000..7d8a4986d35f
--- /dev/null
+++ b/app-emacs/typescript-mode/files/50typescript-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'typescript-mode "typescript-mode"
+ "Major mode for editing typescript." t)
+(add-to-list 'auto-mode-alist '("\\.ts\\'" . typescript-mode))
diff --git a/app-emacs/typescript-mode/metadata.xml b/app-emacs/typescript-mode/metadata.xml
new file mode 100644
index 000000000000..96355bfba917
--- /dev/null
+++ b/app-emacs/typescript-mode/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/emacs-typescript/typescript.el/issues/</bugs-to>
+ <remote-id type="github">emacs-typescript/typescript.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/typescript-mode/typescript-mode-0.4.ebuild b/app-emacs/typescript-mode/typescript-mode-0.4.ebuild
new file mode 100644
index 000000000000..cdb6b235f506
--- /dev/null
+++ b/app-emacs/typescript-mode/typescript-mode-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="TypeScript-support for Emacs"
+HOMEPAGE="https://github.com/emacs-typescript/typescript.el/"
+SRC_URI="https://github.com/emacs-typescript/typescript.el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/typescript.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l typescript-mode-tests.el \
+ -f ert-run-tests-batch-and-exit || die
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc README.md
+}