summaryrefslogtreecommitdiff
path: root/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
commit2f51c9978dda4c6e8debca43e4235ecc86914032 (patch)
treebc41e1c4383040034174c327504f702c8517a123 /app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
parent51536d2fe4697ba9114d611178bb9e20d3d5b729 (diff)
gentoo resync : 25.12.2017
Diffstat (limited to 'app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild')
-rw-r--r--app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild b/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
index b858dc10fc4e..1e802fc217fc 100644
--- a/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
+++ b/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
inherit elisp elisp-common eutils
-if [ "${PV}" = "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/hayamiz/twittering-mode.git"
- inherit git-2
- SRC_URI=""
- KEYWORDS=""
+ inherit git-r3
IUSE="doc"
else
SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
@@ -29,7 +27,7 @@ RDEPEND="app-crypt/gnupg"
src_compile() {
elisp-compile twittering-mode.el || die
- [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+ [[ ${PV} == *9999 ]] && use doc && emake -C doc/manual
}
src_test() {
@@ -37,6 +35,6 @@ src_test() {
}
src_install() {
- [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ [[ ${PV} == *9999 ]] && use doc && dodoc doc/manual/twmode/twmode.html
elisp-install ${PN} twittering-mode.el *.elc || die
}