summaryrefslogtreecommitdiff
path: root/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild')
-rw-r--r--app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild b/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
new file mode 100644
index 000000000000..1e802fc217fc
--- /dev/null
+++ b/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp elisp-common eutils
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hayamiz/twittering-mode.git"
+ inherit git-r3
+ IUSE="doc"
+else
+ SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RESTRICT="test"
+ IUSE=""
+fi
+
+DESCRIPTION="Emacs major mode for Twitter"
+HOMEPAGE="http://twmode.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="app-crypt/gnupg"
+
+src_compile() {
+ elisp-compile twittering-mode.el || die
+ [[ ${PV} == *9999 ]] && use doc && emake -C doc/manual
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ [[ ${PV} == *9999 ]] && use doc && dodoc doc/manual/twmode/twmode.html
+ elisp-install ${PN} twittering-mode.el *.elc || die
+}