summaryrefslogtreecommitdiff
path: root/app-emacs/treepy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /app-emacs/treepy
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'app-emacs/treepy')
-rw-r--r--app-emacs/treepy/Manifest4
-rw-r--r--app-emacs/treepy/files/50treepy-gentoo.el1
-rw-r--r--app-emacs/treepy/metadata.xml18
-rw-r--r--app-emacs/treepy/treepy-0.1.1.ebuild19
4 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/treepy/Manifest b/app-emacs/treepy/Manifest
new file mode 100644
index 000000000000..d3e38a0a29e9
--- /dev/null
+++ b/app-emacs/treepy/Manifest
@@ -0,0 +1,4 @@
+AUX 50treepy-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST treepy-0.1.1.tar.gz 125004 BLAKE2B 2aab285f0a0ce0d14cde0d6567efd062d4e2bf944421e8c4e5c3ef62965a43c7abc77d88c5baeadbe2cbe4e98dce9d563fc5b02abae8e83194dbb058d78db725 SHA512 70790f83e7f33846ca4c568c79c45bfea9a29cc92b717053eb2fa89a22a77578d80f31f19002c61d254d4b2c4c36f345324c0d631412477f09713b51124dfb83
+EBUILD treepy-0.1.1.ebuild 453 BLAKE2B b9b96c7e74b7d5d1f5295ffc117a4ed9548a75916918f68f10f2f8c741dd8f18f7ffe961e668d4336d53d702792b717d037547f1ea9536a2ce9f3002ec396c2f SHA512 38fb8f29b21d8141bbba176cedd45dca85aae3b662866114c25f3e178079cf4b49e628dc78639394a7af7dca5f27430097c12a5e0db9a3bef6dd231665780966
+MISC metadata.xml 618 BLAKE2B 949af96bccf3ac8eae49864c76bac1d675d470e1b9ea9f4cd4a3fa674a97450a6591a08b1bb569a6c1ec477f20bd38b9d0a0808005c95bb6e0c919986d78692a SHA512 1289a6357bcda76f8bf2f7fc35638e2f6e26e3cdf895ba31acf66253bc827fbb7122c215ad795c68a9309574b97af0487bc3c7d81404e92be91adde9f4d6504b
diff --git a/app-emacs/treepy/files/50treepy-gentoo.el b/app-emacs/treepy/files/50treepy-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/treepy/files/50treepy-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/treepy/metadata.xml b/app-emacs/treepy/metadata.xml
new file mode 100644
index 000000000000..4d60dd6e94bb
--- /dev/null
+++ b/app-emacs/treepy/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+Generic tools for recursive and iterative tree traversal based on
+clojure.walk and clojure.zip respectively. Depends on `map', a map
+manipulation library built in Emacs 25.1. All functions are prefixed
+with "treepy-"
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">volrath/treepy.el</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/treepy/treepy-0.1.1.ebuild b/app-emacs/treepy/treepy-0.1.1.ebuild
new file mode 100644
index 000000000000..9e85cb0c484d
--- /dev/null
+++ b/app-emacs/treepy/treepy-0.1.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Generic tree traversing tools for Emacs Lisp"
+HOMEPAGE="https://github.com/volrath/treepy.el"
+SRC_URI="https://github.com/volrath/treepy.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.el-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"