summaryrefslogtreecommitdiff
path: root/app-emacs/treepy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-emacs/treepy
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-emacs/treepy')
-rw-r--r--app-emacs/treepy/Manifest4
-rw-r--r--app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch12
-rw-r--r--app-emacs/treepy/treepy-0.1.1-r1.ebuild20
-rw-r--r--app-emacs/treepy/treepy-0.1.1.ebuild2
4 files changed, 36 insertions, 2 deletions
diff --git a/app-emacs/treepy/Manifest b/app-emacs/treepy/Manifest
index 30f05437a062..14d9b9c5afbe 100644
--- a/app-emacs/treepy/Manifest
+++ b/app-emacs/treepy/Manifest
@@ -1,4 +1,6 @@
AUX 50treepy-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+AUX treepy-0.1.1-cl-lib.patch 212 BLAKE2B dd02f351874992c28686f707a17af43baff592ce60c64da5c445f47f51aa34df3a50d3178ba23220a0c6ba74d0fd064c4b53aeed2a23ce8bf1c55604b3d8b7fb SHA512 940e685ce153e43d55fe414c997ad0fabf4e6f1c07e5657a27868935ce5b88132709c03ff43f69e7feb359ff63ecbda47ce50a84f183559d77869c4379964208
DIST treepy-0.1.1.tar.gz 125004 BLAKE2B 2aab285f0a0ce0d14cde0d6567efd062d4e2bf944421e8c4e5c3ef62965a43c7abc77d88c5baeadbe2cbe4e98dce9d563fc5b02abae8e83194dbb058d78db725 SHA512 70790f83e7f33846ca4c568c79c45bfea9a29cc92b717053eb2fa89a22a77578d80f31f19002c61d254d4b2c4c36f345324c0d631412477f09713b51124dfb83
-EBUILD treepy-0.1.1.ebuild 456 BLAKE2B 6646ce95b766db53c6bb74413666d46c93bd05f1a25e289bfa07d01cde6c20642dd965bcf5400b0dafaf1b2946a1810ac03841b700a77d25a908224df04b709c SHA512 762dd1bbd6fac5889e49d0cf8110e0fcf7067c2bf11f423dff4ed1831bd9cd671918a4e8bca56ee01ff9b9368824c6b650c4bb758290a06469b71f08662e645c
+EBUILD treepy-0.1.1-r1.ebuild 501 BLAKE2B 1fccba73e9008060156e4c3e7c5a1c613561c81bca3ba63495bdc800dc84a04d5fff24c291306ee435355fe6528896afc424d27375d307bb10903ab48c1d7c69 SHA512 20e221cda0c19adc71c874134a2155bf13b30fc9b902b2b23bda0346bffd03c5c4fe3eac367b55eeaa0fb4a6254542bc7f77f3edf88c71bee02796a7546dfdd2
+EBUILD treepy-0.1.1.ebuild 457 BLAKE2B 343e71d20553617a3cd7f10c59240ee2e181d3b551bd9e3a5680e56f9d46002c249f2824c78d3cdb7da09d447830a9e25318b6c64581bc9d3ccf1310c6afa7fd SHA512 5baabe8ff0c74624c6dbca62cb619a4324fe27f4c8c1d13af129dac71117c77ab601b1c796f15cb29ee53401aa416abfd9b6a570af4c29e984aeac4499b87a47
MISC metadata.xml 618 BLAKE2B 949af96bccf3ac8eae49864c76bac1d675d470e1b9ea9f4cd4a3fa674a97450a6591a08b1bb569a6c1ec477f20bd38b9d0a0808005c95bb6e0c919986d78692a SHA512 1289a6357bcda76f8bf2f7fc35638e2f6e26e3cdf895ba31acf66253bc827fbb7122c215ad795c68a9309574b97af0487bc3c7d81404e92be91adde9f4d6504b
diff --git a/app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch b/app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch
new file mode 100644
index 000000000000..0c7bfbad1b85
--- /dev/null
+++ b/app-emacs/treepy/files/treepy-0.1.1-cl-lib.patch
@@ -0,0 +1,12 @@
+Fix byte-compilation with Emacs 27.
+
+--- treepy.el-0.1.1-orig/treepy.el
++++ treepy.el-0.1.1/treepy.el
+@@ -40,6 +40,7 @@
+ ;;
+ ;;; Code:
+
++(require 'cl-lib)
+ (require 'map)
+
+ ;;; Walk (recursive tree traversal)
diff --git a/app-emacs/treepy/treepy-0.1.1-r1.ebuild b/app-emacs/treepy/treepy-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..ed95978e0603
--- /dev/null
+++ b/app-emacs/treepy/treepy-0.1.1-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Generic tree traversing tools for Emacs Lisp"
+HOMEPAGE="https://github.com/volrath/treepy.el"
+SRC_URI="https://github.com/volrath/treepy.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.el-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=("${FILESDIR}"/${P}-cl-lib.patch)
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
diff --git a/app-emacs/treepy/treepy-0.1.1.ebuild b/app-emacs/treepy/treepy-0.1.1.ebuild
index 60192956e0d2..801255838667 100644
--- a/app-emacs/treepy/treepy-0.1.1.ebuild
+++ b/app-emacs/treepy/treepy-0.1.1.ebuild
@@ -11,7 +11,7 @@ HOMEPAGE="https://github.com/volrath/treepy.el"
SRC_URI="https://github.com/volrath/treepy.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}.el-${PV}"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 x86"