summaryrefslogtreecommitdiff
path: root/app-emacs/treemacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-09 00:31:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-09 00:31:01 +0100
commit85e9aa4b6ca3ad1da1147e6d728e350e11266456 (patch)
treeb637dd642620d99909f84bd226fbf6baadf27ffe /app-emacs/treemacs
parentc510d9ec7aca9b092e381a7a4ff213757c7a9709 (diff)
gentoo auto-resync : 09:04:2024 - 00:31:01
Diffstat (limited to 'app-emacs/treemacs')
-rw-r--r--app-emacs/treemacs/Manifest2
-rw-r--r--app-emacs/treemacs/treemacs-3.1_p20240229.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/app-emacs/treemacs/Manifest b/app-emacs/treemacs/Manifest
index 8c8d406bd550..e0ef318512a2 100644
--- a/app-emacs/treemacs/Manifest
+++ b/app-emacs/treemacs/Manifest
@@ -3,5 +3,7 @@ AUX treemacs-2.9.5-tests.patch 342 BLAKE2B c3ea6362372e732c6ab12621ddb4522a0dc02
AUX treemacs-async-scripts.patch 1651 BLAKE2B bd6aecaff19f87e843c3feb17a7a6b63186779d259933a647c66fd9dd26884e729baf726e038aba13fbcc3c41f56d2159379c3001fe91b009f9c51f3728a54d7 SHA512 94094629d2b78fd88da344e0078ddc043c2edce18f1a373116da2db977a2f6d4141801b8d02c64e67ad41f6c9bec966a88ba3aea33a80021d171a3ae862146e0
AUX treemacs-icons-icon-directory.patch 415 BLAKE2B d53b7bfcca7ab85953e1d98a71d58d273f625e095c72417d0c3e1bcfa65d4e5b9a34a60f1295f68a22f663643a6460adddfd2b03c38f7a10a0c3edfae232fb61 SHA512 c76ead6a99de0494769f35af8e3a5154fed728736e41d9cfe08c04f947959a972488e9d6e871e05b10763551fdcbda8e31e9b1bc308a043b5b315ea0a6e475f9
DIST treemacs-3.1.tar.gz 4562915 BLAKE2B b728c6ea795fe1159c2342b593cc4e6b3d06a1ba58dca876e5472e394b77a3a9930740aa9ecb65973f551322018920f08b0b49e897d5677b7a0f1da42cfad2d3 SHA512 e891cfa68916ecc250ab0446a4eb0149deea17a7f366870ce757e73f175bc823dae87080a584ea315d502c50559d030055f2f399cbd92d40af8c2dca5308604c
+DIST treemacs-3.1_p20240229.tar.gz 4701534 BLAKE2B 3b3e5dbef181efee4739f96ee0ef0de68f344fa68b890b22c0ec808ec1c3b7afc6cd353124e2c6e5e70c931492ac0c9a3e4cee5c66b5c25ba4cc72b296ade6f0 SHA512 40631b77a71b13b0aed2f703386d98b8444c7630f952ba8d49160ba99abc13b8636169fee8cd23bbc372a7d7ae83b863e11ac891deb8cc5d2e961ccfee9f60da
EBUILD treemacs-3.1-r1.ebuild 1552 BLAKE2B 70b59cc7ce307911bcaffe310c9b04402092c52b4a467041be36500bb0848e1407be8eb6280289d5b709fdba7346b146abd4c465505dd131e91dc3e258f10ae0 SHA512 4ba84cf9b4925b62dce67819c61287694e6e67dd2555777214251be8c10598d27c45faf64bb32964795e8d4211de0b9e7abcc76c71264b7cf0ba7af1223ad1fa
+EBUILD treemacs-3.1_p20240229.ebuild 1658 BLAKE2B 919e48de8b009478e85affde091294fc7127bbf1535ebc3d3b880133c63f156eab948ceeb7673c7d80667c6e2ef021584ea9dbcddc6ecff5f5b47bfc49d1e34e SHA512 78c2dce31ce581400ad678e33db60a1a42727c19ede77bc1da0050679859da7b757b805911a5c6db415e8ea5af42b2c4ba4fa6ae1629f18b1ad3ab9100c97b0e
MISC metadata.xml 439 BLAKE2B a5536ef58177b5a4802017b81c68951ff5585a745ebc38f036bf2ee98bf6f51b0586ff5022cd1da55dbca13430b1811d8ac60e5b920caec7ea15f83f62ed3cad SHA512 cb6043bf4aa0e741f19630393ec1a25ab74e4ac2f17a41d932fce8d6f95663534cf28c277912c1800b252a98f1dc5ba13d6623f12251486e93dc33df1b77f443
diff --git a/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild b/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild
new file mode 100644
index 000000000000..b7337b3db652
--- /dev/null
+++ b/app-emacs/treemacs/treemacs-3.1_p20240229.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 elisp
+
+DESCRIPTION="Tree style project file explorer"
+HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Alexander-Miller/${PN}.git"
+else
+ COMMIT_SHA=8c6df39f01a4d47fda2cc943645fa067f771b748
+ SRC_URI="https://github.com/Alexander-Miller/${PN}/archive/${COMMIT_SHA}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT_SHA}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}[svg]
+ app-emacs/ace-window
+ app-emacs/cfrs
+ app-emacs/dash
+ app-emacs/ht
+ app-emacs/hydra
+ app-emacs/pfuture
+ app-emacs/s
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+BYTECOMPFLAGS="-L . -L src/elisp"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.9.5-tests.patch"
+ "${FILESDIR}/${PN}-async-scripts.patch"
+ "${FILESDIR}/${PN}-icons-icon-directory.patch"
+)
+
+DOCS=( Changelog.org Extensions.org README.org screenshots )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup test
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -e "s|@SITEETC@|${SITEETC}/${PN}|g" \
+ -i "src/elisp/${PN}-icons.el" \
+ -i "src/elisp/${PN}-async.el" \
+ || die
+}
+
+python_compile() {
+ python_optimize "${S}/src/scripts"
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ elisp-compile src/elisp/*.el
+}
+
+src_install() {
+ elisp-install "${PN}" src/elisp/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r icons
+ doins -r src/scripts
+}