summaryrefslogtreecommitdiff
path: root/app-emacs/transient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-03 04:43:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-03 04:43:49 +0100
commit9b22dab88308071d43d47cd078b37903900f47d3 (patch)
tree67e9a0a10dcdbe72770cc89ba63028a4a8efd711 /app-emacs/transient
parentf354cd2612137255e64a82b6578696697b0415b4 (diff)
gentoo auto-resync : 03:10:2024 - 04:43:49
Diffstat (limited to 'app-emacs/transient')
-rw-r--r--app-emacs/transient/Manifest2
-rw-r--r--app-emacs/transient/transient-0.7.6.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index d37554e5e10b..1401f9b48509 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -1,4 +1,6 @@
DIST transient-0.7.5.tar.gz 141189 BLAKE2B 55535f6121467a1f380ec8d6a4afbb810556f914dc30a7c2fb913f2238bd47809f3d8aadfe35cfdae087525048e83beb14380cd3fdf6cae59643191147df4789 SHA512 18d051235b15e95312fcd60ddfa0f0ba85351d6102117717c81f621528a46a6d0f03d918002a7af2702135ebcf53c498f079a12d99ffc68711e20b196045e032
+DIST transient-0.7.6.tar.gz 141843 BLAKE2B 30ef7aaa1c90a66ab377f076c6a75f217ae1bf40d9541558c0a21a258a53d3c980d7d305658d644e345fcafd3fe6722054ec6154616c6f9dd917a94c70f93fa4 SHA512 315af2dd6f9503f1f695dcb85c8a157651c1b0df4d5272d6a16c0e579213c475a4637db8f262016ef4a99a532c7b5d8c1c9a4ac456ac6deb7d711c6490af2b11
EBUILD transient-0.7.5.ebuild 818 BLAKE2B 0754021978ab2cac0edb05eb9c1a886c616b4d96182f8df774cd636f7137fc38ff18ec717e2fcb309e2c533c94c1a1851428a427ec721e76023a33038de598c7 SHA512 0b0d3166d3428f7b652c18a0855346767d11ab77782b204e469743ba8654fa16b50450ef0ab75994b90849160573400f2bb319b7605f6a9df928d7b22d282fe2
+EBUILD transient-0.7.6.ebuild 820 BLAKE2B 76547cddda312d94a13d084390a7458c797cf38b733e1ae18415a5258ae4ca8ff7f7fe9257efa2fcb3a40a10f0dcd110ed6fc67bdb9edc493db69b1e3d4cef8e SHA512 77577a6f96888ce5e7aeaa1b0daf9cefbd9b7c3693bd1840dd93c1eb3e6881892179792411fecec62ee930b988066605328959eb587ae5a8ee84c6b2fa740658
EBUILD transient-9999.ebuild 820 BLAKE2B 76547cddda312d94a13d084390a7458c797cf38b733e1ae18415a5258ae4ca8ff7f7fe9257efa2fcb3a40a10f0dcd110ed6fc67bdb9edc493db69b1e3d4cef8e SHA512 77577a6f96888ce5e7aeaa1b0daf9cefbd9b7c3693bd1840dd93c1eb3e6881892179792411fecec62ee930b988066605328959eb587ae5a8ee84c6b2fa740658
MISC metadata.xml 1434 BLAKE2B 6f7f91e2cd8c87559f15552d6fbe920e5262a50f21919a096af55df037726eb380a774cfba8be73b588ba9aa2c39da5caf6ad64a31106b843c6bd308fe7aa40e SHA512 3316d9ac21d2a2aa0a5824f2c8ded736ad1bfcd7319a9c4cb8b02f0ffec5f440820bfe48e4f4d4264fbc3864bd7959875f1396285b6a7eb2ad3333a6a062a14f
diff --git a/app-emacs/transient/transient-0.7.6.ebuild b/app-emacs/transient/transient-0.7.6.ebuild
new file mode 100644
index 000000000000..f99ae40b0465
--- /dev/null
+++ b/app-emacs/transient/transient-0.7.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org "docs/${PN}.org" )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ elisp_src_prepare
+}