summaryrefslogtreecommitdiff
path: root/app-emacs/transient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-11 02:01:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-11 02:01:11 +0000
commit494ca58c9f5243dd4b56557aa8c41bce76e95ec3 (patch)
treeb699beb74ae3071c865d4f2e95ed7f376f99214a /app-emacs/transient
parent59437d191de3ff33f9bfa37f8656d849184fcaf0 (diff)
gentoo auto-resync : 11:12:2024 - 02:01:11
Diffstat (limited to 'app-emacs/transient')
-rw-r--r--app-emacs/transient/Manifest2
-rw-r--r--app-emacs/transient/transient-0.8.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index 79c8c8ab88e7..945afa43a7fa 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -1,4 +1,6 @@
DIST transient-0.7.9.tar.gz 144323 BLAKE2B 458fc59484d9a8b39e6810ece2f7eea43493d58107b3bf0950f87c6325ed7812b87eddb335a00094bd298e4a7a71b42a1388c8cf4d4e6f6cba0cea53fd6b6cfa SHA512 176082cc56d495d5fb0776abf16a9ddbe45fc0c0efefa6b1d2724689134ecacdb9630fa4b2d5034e16c716f0772a921125602b09ee07acb013e026eb55ff4998
+DIST transient-0.8.1.tar.gz 152761 BLAKE2B cc62becaff81b803cf0a7c843b1da4996cd06171ac151c1e54381f4e3d54b1b17105557577bd3fe1ae8fca2041c556dccbaf6a000ed1eef14434404b7f8022c5 SHA512 7d278452dbbd259654aa5f9576b94613224b7243f26445a364081a7e50eaf8fcc82d2699dceeffdd9a1364bcd4bc27af139b73ac90c251c45332247c0fe61c66
EBUILD transient-0.7.9.ebuild 818 BLAKE2B 0754021978ab2cac0edb05eb9c1a886c616b4d96182f8df774cd636f7137fc38ff18ec717e2fcb309e2c533c94c1a1851428a427ec721e76023a33038de598c7 SHA512 0b0d3166d3428f7b652c18a0855346767d11ab77782b204e469743ba8654fa16b50450ef0ab75994b90849160573400f2bb319b7605f6a9df928d7b22d282fe2
+EBUILD transient-0.8.1.ebuild 820 BLAKE2B 76547cddda312d94a13d084390a7458c797cf38b733e1ae18415a5258ae4ca8ff7f7fe9257efa2fcb3a40a10f0dcd110ed6fc67bdb9edc493db69b1e3d4cef8e SHA512 77577a6f96888ce5e7aeaa1b0daf9cefbd9b7c3693bd1840dd93c1eb3e6881892179792411fecec62ee930b988066605328959eb587ae5a8ee84c6b2fa740658
EBUILD transient-9999.ebuild 820 BLAKE2B 76547cddda312d94a13d084390a7458c797cf38b733e1ae18415a5258ae4ca8ff7f7fe9257efa2fcb3a40a10f0dcd110ed6fc67bdb9edc493db69b1e3d4cef8e SHA512 77577a6f96888ce5e7aeaa1b0daf9cefbd9b7c3693bd1840dd93c1eb3e6881892179792411fecec62ee930b988066605328959eb587ae5a8ee84c6b2fa740658
MISC metadata.xml 1434 BLAKE2B 6f7f91e2cd8c87559f15552d6fbe920e5262a50f21919a096af55df037726eb380a774cfba8be73b588ba9aa2c39da5caf6ad64a31106b843c6bd308fe7aa40e SHA512 3316d9ac21d2a2aa0a5824f2c8ded736ad1bfcd7319a9c4cb8b02f0ffec5f440820bfe48e4f4d4264fbc3864bd7959875f1396285b6a7eb2ad3333a6a062a14f
diff --git a/app-emacs/transient/transient-0.8.1.ebuild b/app-emacs/transient/transient-0.8.1.ebuild
new file mode 100644
index 000000000000..f99ae40b0465
--- /dev/null
+++ b/app-emacs/transient/transient-0.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org "docs/${PN}.org" )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ elisp_src_prepare
+}