summaryrefslogtreecommitdiff
path: root/app-emacs/transient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-28 21:15:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-28 21:15:34 +0100
commit14bda3c9c57c13e8a59303f400678313fd770bdd (patch)
tree1d76323e4e249e0515128cd6ca42e167a9575294 /app-emacs/transient
parente5346f2f512bd7faf413f3de3ef7fbcfbcd974b3 (diff)
gentoo auto-resync : 28:05:2023 - 21:15:34
Diffstat (limited to 'app-emacs/transient')
-rw-r--r--app-emacs/transient/Manifest1
-rw-r--r--app-emacs/transient/transient-9999.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index 056dfaa79858..ee987859808e 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -5,4 +5,5 @@ DIST transient-0.4.0.tar.gz 128429 BLAKE2B cd97b5fcef5d7d4bb14677ab1fa4a49f16af5
EBUILD transient-0.3.7.ebuild 618 BLAKE2B caa55a263afc6fb555886e6511ab0502e20a3135a1a60ab2fc5311ef92a8ec506f1a44d967eb8318008c263c34322b381a9a9dc816955a73c0764e9f5baf1398 SHA512 1a9aa9bf670f7c0084c70a52d9782e1e759e0aaf0c79bb81fc25fd03fa41c00c932053c622ad681591d31c07af5955c0512f56a47a3b70d7eb1f7d5ac93c584a
EBUILD transient-0.3.7_p20220918-r1.ebuild 719 BLAKE2B c64dfa62198be34fac7e1b153d07b68e67e544b26f41c4b84f87bfe49c4b62b21fc32b7f203604c3425ad1e734c76c11b76883457d491f36eea0967f7cf156a9 SHA512 6840921d56497567a0ce9a5d3ebe0c6ccfce46c13816e13458d832da5fdef81ef807b56fbb2293c898adb923409f6aa20427be20d3cf36baf11502328913eaac
EBUILD transient-0.4.0.ebuild 686 BLAKE2B d6390ae4054e664299978683bcf1f869171f013e8c7a72843f732a2769deb501526dfcde187a9d5c8c6d501ae612c35caa15a37a1037b92fccfdc65a50fcba15 SHA512 5bd586bd6a3f8f6629f8befaa9bc9242b74fd06cf8ec761bb8eb97e3f97e3a2830b20416349177aa22e43e52c22664a2976575e52650589d8a61476f191e42d6
+EBUILD transient-9999.ebuild 794 BLAKE2B 562b327a7f3755266b154a947ed356dfc53e6cec857829e560028c594aefe8bce170062756eabe9ae3406a0b40a0cc8ef8e41fc5f77074cf9e7e7f37fc6c0c01 SHA512 52c14825987d0aa2d3e651fa0e0401f4bc3e4d05037ea20c3715e8846e579d30c8ed12ff018228326b614d244fcca04eb4e9b58784851b1025b6c14a5e81933a
MISC metadata.xml 1434 BLAKE2B 6f7f91e2cd8c87559f15552d6fbe920e5262a50f21919a096af55df037726eb380a774cfba8be73b588ba9aa2c39da5caf6ad64a31106b843c6bd308fe7aa40e SHA512 3316d9ac21d2a2aa0a5824f2c8ded736ad1bfcd7319a9c4cb8b02f0ffec5f440820bfe48e4f4d4264fbc3864bd7959875f1396285b6a7eb2ad3333a6a062a14f
diff --git a/app-emacs/transient/transient-9999.ebuild b/app-emacs/transient/transient-9999.ebuild
new file mode 100644
index 000000000000..adb9d5ff1a85
--- /dev/null
+++ b/app-emacs/transient/transient-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org docs/${PN}.org )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND=">=app-emacs/compat-29.1.4.1"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}