summaryrefslogtreecommitdiff
path: root/app-emacs/thinks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/thinks
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/thinks')
-rw-r--r--app-emacs/thinks/Manifest6
-rw-r--r--app-emacs/thinks/files/50thinks-gentoo.el31
-rw-r--r--app-emacs/thinks/metadata.xml8
-rw-r--r--app-emacs/thinks/thinks-1.9.ebuild17
4 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/thinks/Manifest b/app-emacs/thinks/Manifest
new file mode 100644
index 000000000000..e16d9eaa82cf
--- /dev/null
+++ b/app-emacs/thinks/Manifest
@@ -0,0 +1,6 @@
+AUX 50thinks-gentoo.el 852 SHA256 c37f94cd63bd7355365753c1bdd42bb89aedcb3aaa2d3198ea067abfb61d1a7d SHA512 c82105986cd349a7716ac1ee1b54f16101719aa6f14a3485ec7942b8704c6fd748e5eba708064607c15a50158df64d7591af90a7bdb38ba7e0ed6c0811ca9897 WHIRLPOOL 25a3fb3fdf96e2a553c462d78fc2d94f8d7161690bcd66a9dfc4bf8cdca9139cba086b527e29847cda00abf659f9ee4ef0b56fa5d8ca6dc4621c2b5792de8508
+DIST thinks-1.9.el.bz2 2989 SHA256 fe51755231be601686a10901af276de9d746ef71b57b0954a21f0e9a98b35d38 SHA512 ba85485df0decb2825a832b60b01a4ae8ef2e32dc356d16b770a4b59a795e138f3c26e14d8eb27e97038d10d2633945c7b2bd14933fdf7815f6c0abc07de5802 WHIRLPOOL 32981107e64cd04aafe8d52ef2bf4a2b3ab2b5589514591437b0422a82ae7fd7e2ab92955a4ecccf58769858fbe0e37765c63db1304acd2fd54fe03a67df0f49
+EBUILD thinks-1.9.ebuild 407 SHA256 32f50a298038c6cbf5646a93ce390ade517a7bf437d37a66ea37491749e3c7b0 SHA512 1d6dc2def9daeb1fcc27568c46f93ed47f2270b7473788d05788446b63009022d5ec93e9ae99e5fbf7ee670644f385848a683f4da288966f0ce7941c7b374c24 WHIRLPOOL c6fe2b49fbf44b935f965858298b648853a31bcfcf230471b58b80b7509b0a4518ce4a3abbc1de26ab5a7504eb4a2e90670b181c796fcf59f8d2b815ef1e6a10
+MISC ChangeLog 2356 SHA256 ee92a750fa72e23cb906f67050f4869bccdb6eefe8f39ca69991b00d879af43b SHA512 0ed89a9c477a78ada3132821bd5a3a4f74c713e82160d0acb3357da22e29f8021efef1d2fd4672b10621983604ede7cf0c464ec61c09638b9de8655955f0688b WHIRLPOOL eff0a4a138ee43d344ad0d7b013c1a4a5185b3ff28bead9b3fdbc1aef36876fecac28d6ee43d998b79ea1e024b4d2a7ef9384f3c5396025885fed8e9caaeb25a
+MISC ChangeLog-2015 1374 SHA256 efb59653740ee63058491a0f872ac94190d24fa61c24c9ff5f184ee6be5becda SHA512 5249a0d37bcebea1ff25aeca34cfbca45df5622129004c11142a589dd9aab93ca882770fd42cb382b0a4f564292ea0e95a95a001f87098a51c456f9759b025fb WHIRLPOOL cd1c9d8557ef33869e7265e371be433c45bd1bea80c85256d733c697244e9a21a35cb3aba82659f251993889aeca782bfb7eb0ef0c4325e4cfbda6060449e7b6
+MISC metadata.xml 259 SHA256 4d59c14917cb31648858cb06bc3c7f224cf1c3906dc3166f8f0d8b8e02970928 SHA512 9a5c456aae7919a4cdbb10b67a27c232daf2ec6db4202e04ba6d5873242fc982a659410443dd6fb4498d42af00b495acc51a6a2cbe12aeab91b585dfac7233a3 WHIRLPOOL 08c68f505a8cc685c52f3a54a07582b64ff7c0b4682c8f9333286fbb5caf4a8d406933c7937fe8c9611f456b5a549ee100657a1c9dc766c8965772f277bf31fb
diff --git a/app-emacs/thinks/files/50thinks-gentoo.el b/app-emacs/thinks/files/50thinks-gentoo.el
new file mode 100644
index 000000000000..e9b9968517ac
--- /dev/null
+++ b/app-emacs/thinks/files/50thinks-gentoo.el
@@ -0,0 +1,31 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload (quote thinks) "thinks" "\
+Insert TEXT wrapped in a think bubble.
+
+Prefix a call to this function with \\[universal-argument] if you don't want
+the text to be filled for you.
+
+\(fn TEXT)" t nil)
+
+(autoload (quote thinks-region) "thinks" "\
+Bubble wrap region bounding START and END.
+
+Prefix a call to this function with \\[universal-argument] if you don't want
+the text to be filled for you.
+
+\(fn START END)" t nil)
+
+(autoload (quote thinks-yank) "thinks" "\
+Do a `yank' and bubble wrap the yanked text.
+
+Prefix a call to this function with \\[universal-argument] if you don't want
+the text to be filled for you.
+
+\(fn)" t nil)
+
+(autoload (quote thinks-maybe-region) "thinks" "\
+If region is active, bubble wrap region bounding START and END.
+If not, query for text to insert in bubble.
+
+\(fn)" t nil)
diff --git a/app-emacs/thinks/metadata.xml b/app-emacs/thinks/metadata.xml
new file mode 100644
index 000000000000..c438baf3b326
--- /dev/null
+++ b/app-emacs/thinks/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-emacs/thinks/thinks-1.9.ebuild b/app-emacs/thinks/thinks-1.9.ebuild
new file mode 100644
index 000000000000..4471d2d43248
--- /dev/null
+++ b/app-emacs/thinks/thinks-1.9.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Insert text in a think bubble"
+HOMEPAGE="http://www.davep.org/emacs/"
+# taken from http://www.davep.org/emacs/${PN}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"