summaryrefslogtreecommitdiff
path: root/app-emacs/template
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/template
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/template')
-rw-r--r--app-emacs/template/Manifest4
-rw-r--r--app-emacs/template/files/50template-gentoo.el20
-rw-r--r--app-emacs/template/metadata.xml12
-rw-r--r--app-emacs/template/template-3.1c-r1.ebuild30
4 files changed, 66 insertions, 0 deletions
diff --git a/app-emacs/template/Manifest b/app-emacs/template/Manifest
new file mode 100644
index 000000000000..bde74f79bc64
--- /dev/null
+++ b/app-emacs/template/Manifest
@@ -0,0 +1,4 @@
+AUX 50template-gentoo.el 968 BLAKE2B ed1a12d4f1df94576e0ac7b03bc5a237ae0252ef247780c0fba30f2c4f4d5d72949a9dd9a32c7e91dc08db8e5175ab1138f4b3667397230171fc4d3c9fee79bf SHA512 a6c4fd122ae1daa7e0a07b259dba0581cdd7868d220c107c6979ef5f842659dc51c0573948979d9907241918686b48da4a89baff33abdcb12bfb30941a068396
+DIST template-3.1c.tar.gz 37903 BLAKE2B c6bcd602727d6a6bd60c1b26694b98b28f4f7c752c8c31cd2ad9359297265579b1317effadad956e5aba455b22714985367e84f3295528a1dcc09ff50bf9882d SHA512 d9fee39b67ff986d7c2dccbd09af3ce208f0e1a616a406fefefe4a6399f69a3527fa5609e87d41f7ceec5bf95818a62cb8da62994b28945998f8a9074821914c
+EBUILD template-3.1c-r1.ebuild 637 BLAKE2B c7650230d15b08ba5df4a15c027264bb6350fef406625a8d6c74fbf063c51a483f4566f7c6ae059ae1ad42a839148b6c4f379d1a9fed8c4b47a088cf740970de SHA512 601ef1ba2db841a2be31f8f0cb9049b5c4e596073284fedd82c79af20fb6ad42c145e64c8e61caa6bf14df0064e5414fbbf597e5a28497e9c1ca4461de6c01bc
+MISC metadata.xml 364 BLAKE2B 51a9622045ca4a82d2ba9387fbba67f0c0e42de533bf282b0484c0fdc1e2f9abce019cf26ab9319ab6f22d9064698299ef2a253517153e6f19f68594659b1730 SHA512 ad25ac4e50e673d017b8c85ac0d69c0794995a17a915fab741e97d966d0478d4523f833f890afeb2d4e0aa31907fb25fc505b282f95fd7a223c2902a0e0b2086
diff --git a/app-emacs/template/files/50template-gentoo.el b/app-emacs/template/files/50template-gentoo.el
new file mode 100644
index 000000000000..3da76196f42e
--- /dev/null
+++ b/app-emacs/template/files/50template-gentoo.el
@@ -0,0 +1,20 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'template-single-comment "template"
+ "Decorate the comment in the current line with dashes and alike." t)
+(autoload 'template-block-comment "template"
+ "Decorate the current block of comment-only lines with dashes and alike." t)
+(autoload 'template-update-header "template"
+ "Replace old file name in header with current file name." t)
+(autoload 'template-expand-template "template"
+ "Expand template file TEMPLATE and insert result in current buffer." t)
+(autoload 'template-new-file "template"
+ "Open a new file FILE by using a TEMPLATE." t)
+(autoload 'template-initialize "template"
+ "Initialized package template. See variable `template-initialize'." t)
+
+(setq template-default-directories
+ (list (if (and (not (file-directory-p "~/.templates/"))
+ (file-directory-p "~/lib/templates"))
+ (expand-file-name "~/lib/templates/")
+ (expand-file-name "~/.templates/"))
+ "@SITEETC@/templates"))
diff --git a/app-emacs/template/metadata.xml b/app-emacs/template/metadata.xml
new file mode 100644
index 000000000000..4af6ef4f062a
--- /dev/null
+++ b/app-emacs/template/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="sourceforge">emacs-template</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/template/template-3.1c-r1.ebuild b/app-emacs/template/template-3.1c-r1.ebuild
new file mode 100644
index 000000000000..4de14534d3c4
--- /dev/null
+++ b/app-emacs/template/template-3.1c-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Use templates, decorate comments, auto-update buffers"
+HOMEPAGE="http://emacs-template.sourceforge.net/"
+SRC_URI="mirror://sourceforge/emacs-template/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile lisp/*.el
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r templates
+ dodoc README lisp/ChangeLog
+}