summaryrefslogtreecommitdiff
path: root/app-emacs/template
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/template
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/template')
-rw-r--r--app-emacs/template/Manifest6
-rw-r--r--app-emacs/template/files/50template-gentoo.el20
-rw-r--r--app-emacs/template/metadata.xml11
-rw-r--r--app-emacs/template/template-3.1c-r1.ebuild30
4 files changed, 67 insertions, 0 deletions
diff --git a/app-emacs/template/Manifest b/app-emacs/template/Manifest
new file mode 100644
index 000000000000..856ecfbf58c3
--- /dev/null
+++ b/app-emacs/template/Manifest
@@ -0,0 +1,6 @@
+AUX 50template-gentoo.el 968 SHA256 863761052d393649d241927d429fe231a6cba5f74dae7148b820d2061147d895 SHA512 a6c4fd122ae1daa7e0a07b259dba0581cdd7868d220c107c6979ef5f842659dc51c0573948979d9907241918686b48da4a89baff33abdcb12bfb30941a068396 WHIRLPOOL 088bcb445758437149273a61e26691358c3af140c26a97bab1c73d7983b6fe8a5076853873fa0c23061c11aa32d3ce18c0b5333d07a48b6cdd6220d452a3b863
+DIST template-3.1c.tar.gz 37903 SHA256 d71885ec8d230a5a7cc909f052b97ed7cc30423ca0e2647392424dfd10459845 SHA512 d9fee39b67ff986d7c2dccbd09af3ce208f0e1a616a406fefefe4a6399f69a3527fa5609e87d41f7ceec5bf95818a62cb8da62994b28945998f8a9074821914c WHIRLPOOL 57043085455aefc5a378fa0d48525d823345932d67c34ceee1c5106481d468c1e9fb8559d511f4184d326e71bd46b9416d92f0c080de04607f559da34c163683
+EBUILD template-3.1c-r1.ebuild 637 SHA256 189d0481b746b3bf82b1837a49ae6b092a3415e2f768f2d0962a36e4e2417b3f SHA512 601ef1ba2db841a2be31f8f0cb9049b5c4e596073284fedd82c79af20fb6ad42c145e64c8e61caa6bf14df0064e5414fbbf597e5a28497e9c1ca4461de6c01bc WHIRLPOOL f2c8f25cf261fcd72052255db7db1e23f9cb6e0a21d355a8978380589a9ab879c8b2b0cf628b84745355e5271378e9988415a1ec45dbf259c809d669eaebe1bf
+MISC ChangeLog 2351 SHA256 83391a886c39273d29f5814bf91c64acbc046e3c2a014f44b9517b17e861544f SHA512 0ba7613b332a91bc029160d04258e39f1433abf4749d5d817ea4983299b00d23ac895d777d3c34eabb5c96817a588f86546e1f110e0d7620791cdd0a23e435b2 WHIRLPOOL da74c3c197a70cdd15c83d7ed9a9d3e49b6e72e770198f572d544b619c817c4c1a5ee67ba861f5677c75b820e01554824b326e6256279c56b0a108d7c11191c0
+MISC ChangeLog-2015 776 SHA256 b197a04a800a5f8c5852685483bbd1a320262c8cf779f74e6c27f9ab76fb0106 SHA512 cd9a2309d8ca0f195a831ce6abaef468f96220f81ae11b83a43f26717f682d3842596754b6169dbad5a1eb0726af9518c2a23b9d2e58a8737bedba90c52bf80c WHIRLPOOL 87e72eeef033a48028e9ed0ffe029c035071bdd24695326fe0041c5d12dcf35f77d95431d0053318b94f49a8470124df643d4e0dfaaf2cbe21305a36c0081e98
+MISC metadata.xml 341 SHA256 e771c7f16536d310d3a7af6ad9ee91446db1eff8c860614c9fc84aa05c9b9b37 SHA512 5bf78455bd9cca318191970e758922dd83f26171d7b103367206044c1c766bc939433a871be14536335419f12d7406a07983cdd15def5d81b1b74c31fd1da623 WHIRLPOOL c068f50d0d9492406dfe516872eb3c58fd90109a2d377056f4afea3c2662c2ef4118e856938952a34a9d67448a6195b8a4f6dd2ba7a34c919af82f2da3a924b9
diff --git a/app-emacs/template/files/50template-gentoo.el b/app-emacs/template/files/50template-gentoo.el
new file mode 100644
index 000000000000..3da76196f42e
--- /dev/null
+++ b/app-emacs/template/files/50template-gentoo.el
@@ -0,0 +1,20 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'template-single-comment "template"
+ "Decorate the comment in the current line with dashes and alike." t)
+(autoload 'template-block-comment "template"
+ "Decorate the current block of comment-only lines with dashes and alike." t)
+(autoload 'template-update-header "template"
+ "Replace old file name in header with current file name." t)
+(autoload 'template-expand-template "template"
+ "Expand template file TEMPLATE and insert result in current buffer." t)
+(autoload 'template-new-file "template"
+ "Open a new file FILE by using a TEMPLATE." t)
+(autoload 'template-initialize "template"
+ "Initialized package template. See variable `template-initialize'." t)
+
+(setq template-default-directories
+ (list (if (and (not (file-directory-p "~/.templates/"))
+ (file-directory-p "~/lib/templates"))
+ (expand-file-name "~/lib/templates/")
+ (expand-file-name "~/.templates/"))
+ "@SITEETC@/templates"))
diff --git a/app-emacs/template/metadata.xml b/app-emacs/template/metadata.xml
new file mode 100644
index 000000000000..ab35afb4a697
--- /dev/null
+++ b/app-emacs/template/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<upstream>
+ <remote-id type="sourceforge">emacs-template</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/template/template-3.1c-r1.ebuild b/app-emacs/template/template-3.1c-r1.ebuild
new file mode 100644
index 000000000000..4de14534d3c4
--- /dev/null
+++ b/app-emacs/template/template-3.1c-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Use templates, decorate comments, auto-update buffers"
+HOMEPAGE="http://emacs-template.sourceforge.net/"
+SRC_URI="mirror://sourceforge/emacs-template/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile lisp/*.el
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r templates
+ dodoc README lisp/ChangeLog
+}