summaryrefslogtreecommitdiff
path: root/app-emacs/tempel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 17:52:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 17:52:12 +0000
commita90c84e720803f3d26c0ade8f1f1e405ca97502a (patch)
treef788ea0972d51c66823825021dd83427e1d466c4 /app-emacs/tempel
parent07c1e2fbaa2f7d2cad4c16a747cebcf7ae7a6724 (diff)
gentoo auto-resync : 14:01:2023 - 17:52:11
Diffstat (limited to 'app-emacs/tempel')
-rw-r--r--app-emacs/tempel/Manifest4
-rw-r--r--app-emacs/tempel/files/50tempel-gentoo.el2
-rw-r--r--app-emacs/tempel/metadata.xml23
-rw-r--r--app-emacs/tempel/tempel-0.6.ebuild25
4 files changed, 54 insertions, 0 deletions
diff --git a/app-emacs/tempel/Manifest b/app-emacs/tempel/Manifest
new file mode 100644
index 000000000000..cf8783b5c9c2
--- /dev/null
+++ b/app-emacs/tempel/Manifest
@@ -0,0 +1,4 @@
+AUX 50tempel-gentoo.el 70 BLAKE2B e302aa20f0a3b8c1b4291520a84b680ded0f26468fc74dd1d57a5f52693e05eb88ee8ddf673c2ad57c3055b5c2e933e6ff119d4016f482e99c0d985bf610b4d0 SHA512 2cb452a2623403100400cd5e74af0741d56cd2d89e93e49245cb86ff09be0d8289fae9760a1fadc637736549da6f0c0b528ea3e02ee495b0ced2093191286c90
+DIST tempel-0.6.tar.gz 25563 BLAKE2B 2edd522335f8faaa989b313b04f394f30f514cf7c40ec20f5f5fe0c1f1fe1b3ae05d15e9deb103e94d3d25b86a5725caa78904a25f22f806453a705dfc5e9c82 SHA512 49938758f5289fc9c77a78dc1559ce6a454d5969b256ba0e18239855ff0667afbb131c8e2214d4994fc342397903a293ad88bf26828c693ec5e197174d78ef50
+EBUILD tempel-0.6.ebuild 498 BLAKE2B c922374280a79bcdf14c03999d9852f0778944828514e50e749c2564445cd4ec7e771d5b7a1628800be7f97327bde564cbb6b07d05f1126634cbdd9272d97aa8 SHA512 35816ede6c1ec8a8759a1664fdb01e653167264cbd2902eda1492815123c06ee379db11dc925533d1d6d5b89184fc585ce84a901d420cebd365fcf54dea899ba
+MISC metadata.xml 1035 BLAKE2B 15f85f975327cc9a96b2682c728ee77d98dd3326cd793bef66e294775b94baee8006b981ccc880ac7940d52ecaa093ac4b5d639dde2141d88b0da1a69cd3c221 SHA512 6599e4a7d5eea0e95a7af53ea17d933bbfbf9313f36e8a777a964715a631f0e8b76e60786df1d59a83cad1b672acfd8f5045e8ecb2595e7e254b77f9402099d8
diff --git a/app-emacs/tempel/files/50tempel-gentoo.el b/app-emacs/tempel/files/50tempel-gentoo.el
new file mode 100644
index 000000000000..4dd9e924962a
--- /dev/null
+++ b/app-emacs/tempel/files/50tempel-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "tempel-autoloads" nil t)
diff --git a/app-emacs/tempel/metadata.xml b/app-emacs/tempel/metadata.xml
new file mode 100644
index 000000000000..d274e25d5a17
--- /dev/null
+++ b/app-emacs/tempel/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Tempel is a tiny template package for Emacs, which uses the syntax of the
+ Emacs Tempo library. Tempo is an ancient temple of the church of Emacs. It
+ is 27 years old, but still in good shape since it successfully resisted
+ change over the decades. However it may look a bit dusty here and there.
+ Therefore we present Tempel, a new implementation of Tempo with inline
+ expansion and integration with recent Emacs facilities. Tempel takes
+ advantage of the standard completion-at-point-functions mechanism which is
+ used by Emacs for in-buffer completion.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/minad/tempel/issues/</bugs-to>
+ <remote-id type="github">minad/tempel</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/tempel/tempel-0.6.ebuild b/app-emacs/tempel/tempel-0.6.ebuild
new file mode 100644
index 000000000000..1d707c8aabb8
--- /dev/null
+++ b/app-emacs/tempel/tempel-0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Templates with in-buffer field editing for GNU Emacs"
+HOMEPAGE="https://github.com/minad/tempel/"
+SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}