summaryrefslogtreecommitdiff
path: root/app-emacs/tdtd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/tdtd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/tdtd')
-rw-r--r--app-emacs/tdtd/Manifest4
-rw-r--r--app-emacs/tdtd/files/50tdtd-gentoo.el28
-rw-r--r--app-emacs/tdtd/metadata.xml9
-rw-r--r--app-emacs/tdtd/tdtd-0.7.1-r1.ebuild22
4 files changed, 63 insertions, 0 deletions
diff --git a/app-emacs/tdtd/Manifest b/app-emacs/tdtd/Manifest
new file mode 100644
index 000000000000..123ab15a6634
--- /dev/null
+++ b/app-emacs/tdtd/Manifest
@@ -0,0 +1,4 @@
+AUX 50tdtd-gentoo.el 742 BLAKE2B 182ef610170ac1de9f8726acb5f9f6673ac8e4a76fc4707ea1b3a713262cc7f3f1e62c75448e64eeaceae83a8a1251b2e461ae2e21ee64320b3960278fa18af9 SHA512 c3a3e7121fa6634c664845584934411a6da2259e1ed839511f0f53d28d87a3f78269d90da16ed91ee8b35d6a5f29245e4d85aaf10b3e20d1ebe6b072a39fb662
+DIST tdtd071.zip 37673 BLAKE2B 0bc5be6e8c9050a06b233b1645fe3bb3ad9bb89ba087309d75afd63af28ce1d4873c88447fcd6e654f50728682d5156e1a795865f11f5e2e54607e630687ed0a SHA512 3de529178718352bc437a3e91d3102990a88314d1dc5ad3d3120c6dfcbb1aef008edc00e46ee051fd5c968c698230393a301dd645484aa748b5b982df84e0556
+EBUILD tdtd-0.7.1-r1.ebuild 506 BLAKE2B b90dad61c9daf9413c3625269ac6c11c4dc6a39b23010e42e434256a088d0257d1caa7376eaa3ad08ebec8593a8c716f7c335be21ab2067fa1f3b0089e37ee8c SHA512 a78911cfc8dd31c7bff52b6decc97a880be0e24e5330a34ff54d503c2421103814d47bc5913fbfa5a968edb6e8f123fe1e9ded016632e97ddb064f4ba40754d3
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/tdtd/files/50tdtd-gentoo.el b/app-emacs/tdtd/files/50tdtd-gentoo.el
new file mode 100644
index 000000000000..3867c8faa137
--- /dev/null
+++ b/app-emacs/tdtd/files/50tdtd-gentoo.el
@@ -0,0 +1,28 @@
+
+;;; tdtd site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'dtd-mode "tdtd" "Major mode to edit DTD files." t)
+(autoload 'dtd-etags "tdtd"
+ "Execute etags on FILESPEC and match on DTD-specific regular expressions."
+ t)
+(autoload 'dtd-grep "tdtd" "Grep for PATTERN in files matching FILESPEC." t)
+
+;; Turn on font lock when in DTD mode
+(add-hook 'dtd-mode-hooks
+ 'turn-on-font-lock)
+
+(setq auto-mode-alist
+ (append
+ (list
+ '("\\.dcl$" . dtd-mode)
+ '("\\.dec$" . dtd-mode)
+ '("\\.dtd$" . dtd-mode)
+ '("\\.ele$" . dtd-mode)
+ '("\\.ent$" . dtd-mode)
+ '("\\.mod$" . dtd-mode))
+ auto-mode-alist))
+
+;; To use resize-minibuffer-mode, uncomment this and include in your .emacs:
+;;(resize-minibuffer-mode)
diff --git a/app-emacs/tdtd/metadata.xml b/app-emacs/tdtd/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/tdtd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/tdtd/tdtd-0.7.1-r1.ebuild b/app-emacs/tdtd/tdtd-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..0d8bb44d238f
--- /dev/null
+++ b/app-emacs/tdtd/tdtd-0.7.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit elisp
+
+DESCRIPTION="Emacs Major Mode for SGML and XML DTDs"
+HOMEPAGE="http://www.menteith.com/wiki/tdtd"
+SRC_URI="http://www.menteith.com/raw-attachment/wiki/tdtd/data/${PN}${PV//./}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+SITEFILE=50${PN}-gentoo.el
+DOCS="TODO changelog.txt readme.txt tutorial.txt"