summaryrefslogtreecommitdiff
path: root/app-emacs/system-packages
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/system-packages
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/system-packages')
-rw-r--r--app-emacs/system-packages/Manifest4
-rw-r--r--app-emacs/system-packages/files/50system-packages-gentoo.el1
-rw-r--r--app-emacs/system-packages/metadata.xml13
-rw-r--r--app-emacs/system-packages/system-packages-1.1.0.ebuild20
4 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/system-packages/Manifest b/app-emacs/system-packages/Manifest
new file mode 100644
index 000000000000..2fd51d70a86a
--- /dev/null
+++ b/app-emacs/system-packages/Manifest
@@ -0,0 +1,4 @@
+AUX 50system-packages-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST system-packages-1.1.0.tar.gz 18634 BLAKE2B ec32510435507bf64c77d7952094eb9fe72d3f7f098335c756fc7d80ce267e02a253fecb406986ec4e09b601868b448b4c9379c29cd5810b634bb07c5f686e5a SHA512 58ecaa8649c086995f68db6abc3bf9cbb012b39b51c553b661368aaed116835984425a6b19d68f8ffad44ecf1818a6281758c56e62ac5230783408e73f9ff776
+EBUILD system-packages-1.1.0.ebuild 461 BLAKE2B 2b2760370484a83ec19e34269611f9d92b79c5f33b62378da51671e7dfa99317b9cfb58f1f0959cd8e2fd1b91aa10abe26714ad5c73937e57ab7fefb6a99e674 SHA512 437922127045e8dfc3606e28170adf8ae0550ecfc8f1007178ca2952fdc7d5e08f764a75a7f832b648510dfccc8a8cc1cb8e02f7d7d668c1d974c175bacc378b
+MISC metadata.xml 441 BLAKE2B 4786f0bacc0545bae309cb51a22e33e0932e1152fdeebf8fa60e39cb04eeeb9f5ac13cc4af84edf2b87d99e28044fcdb450501e35b42a0aadc2fd6e86b1c001a SHA512 c029ef4cf76f34f73f2f910a8ad2df5e28bfe14069bc2f7113543a972f0e24302e77ad37b3ef0f895531c0045fd7925e216f378cc83cf9ff9299cb6f517f5763
diff --git a/app-emacs/system-packages/files/50system-packages-gentoo.el b/app-emacs/system-packages/files/50system-packages-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/system-packages/files/50system-packages-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/system-packages/metadata.xml b/app-emacs/system-packages/metadata.xml
new file mode 100644
index 000000000000..9e1db88b663a
--- /dev/null
+++ b/app-emacs/system-packages/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/jabranham/system-packages/-/issues/</bugs-to>
+ <remote-id type="gitlab">jabranham/system-packages</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/system-packages/system-packages-1.1.0.ebuild b/app-emacs/system-packages/system-packages-1.1.0.ebuild
new file mode 100644
index 000000000000..0c462895c9ad
--- /dev/null
+++ b/app-emacs/system-packages/system-packages-1.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="Manage your installed packages with Emacs"
+HOMEPAGE="https://gitlab.com/jabranham/system-packages/"
+SRC_URI="https://gitlab.com/jabranham/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org )
+ELISP_REMOVE=".dir-locals.el"
+SITEFILE="50${PN}-gentoo.el"