summaryrefslogtreecommitdiff
path: root/app-emacs/swift-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-10 22:28:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-10 22:28:10 +0100
commitf2a91413828611d85d0496e98e1656e9b0e4528b (patch)
treeb3998888d687ece7d9aabfa86c9b449e5438a513 /app-emacs/swift-mode
parentb98a1d0a0651765f29a8aeab25f904e730dfbf88 (diff)
gentoo auto-resync : 10:07:2023 - 22:28:10
Diffstat (limited to 'app-emacs/swift-mode')
-rw-r--r--app-emacs/swift-mode/Manifest2
-rw-r--r--app-emacs/swift-mode/swift-mode-9.0.0.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/swift-mode/Manifest b/app-emacs/swift-mode/Manifest
index 661596b4230f..9bfdbf006dd0 100644
--- a/app-emacs/swift-mode/Manifest
+++ b/app-emacs/swift-mode/Manifest
@@ -1,4 +1,6 @@
AUX 50swift-mode-gentoo.el 176 BLAKE2B 50d8c7580d8b9053bbe94793eb75a80565ed264415a587d7410cfa6259bea9a34b48662f3066abcee9352c2c712aa9d68e8632b23e7511a47947c9b83e64db74 SHA512 3ca3647b549372d5f7493b7eac25ac628f4bc93c6ab6560f724248542ed07557d193a6cf0c2148ea5ed8a7d0d9c9786263c27322daa788894b42c13d7eabdb94
DIST swift-mode-8.6.0.tar.gz 226530 BLAKE2B c3e7a8912a0afbd62adc702f3692ecd4fd8f6938ab838f9e576969f50ded6e32040c33595c61974eb6778bb68ad9d4d0dbc3f5fd1a296a0836829ba93a75158f SHA512 5e8f4d2874dee93b47b4d5a191af7158a2b61f632e3838b0c8617020abc44736f51de40426f5e0bcb8a46844beaf6be310ed9e655fc7638eed3bff0aa78eb101
+DIST swift-mode-9.0.0.tar.gz 227995 BLAKE2B ac60f1dbf03f37a9e95372702f43eceeab2463d579c0e69110921851dc3d549ad32496648bfdca288003e17821dbc92b226d9581ebac8eb7d3e2e07ca4bd2f91 SHA512 affc7606456d44fdd82f7b5b47536e8822c1efb2f1dc49efb09451975b6c95dc9c9445e742a8c1f8038a9799e5cfd73b424ff56f50d9190c3f057bd34fb21f1c
EBUILD swift-mode-8.6.0.ebuild 647 BLAKE2B 82be08adb721bee814b245c2dbaa205915be60dfffc59a4929d6b989bb5bfcdf6c97cdc2fcf7fbac0fc123272e22d04ad6ea03383aeec524811ab88c7b2e5251 SHA512 d28dac00b12fcd61b4025f214b5781aff915bd2c5dce62fa2167f25bc2d60576228590075117a9d1e38d9c730731bf0389d22b88e9fd5ede715db914d4604e6a
+EBUILD swift-mode-9.0.0.ebuild 647 BLAKE2B 82be08adb721bee814b245c2dbaa205915be60dfffc59a4929d6b989bb5bfcdf6c97cdc2fcf7fbac0fc123272e22d04ad6ea03383aeec524811ab88c7b2e5251 SHA512 d28dac00b12fcd61b4025f214b5781aff915bd2c5dce62fa2167f25bc2d60576228590075117a9d1e38d9c730731bf0389d22b88e9fd5ede715db914d4604e6a
MISC metadata.xml 433 BLAKE2B 3af7d408604487fd4253efc78148c0607887c01285a6f0c9eb990bda8ca04b27c6ede80c9816ce4263b714a13da4bd654c05d860a57ece4bb0d685f22a4b9922 SHA512 97bab4e8f2c699941c1d3fe30f0d46afa3b7eb19d1a827df0ded5c5c526f7443cd792cb1b1b346936888b8f0a02775e67f2a1afdaca0bfbe2e2dd74852172619
diff --git a/app-emacs/swift-mode/swift-mode-9.0.0.ebuild b/app-emacs/swift-mode/swift-mode-9.0.0.ebuild
new file mode 100644
index 000000000000..3c78d0b5123e
--- /dev/null
+++ b/app-emacs/swift-mode/swift-mode-9.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs support for Apple's Swift programming language"
+HOMEPAGE="https://github.com/swift-emacs/swift-mode/"
+SRC_URI="https://github.com/swift-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md CONTRIBUTING.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} \
+ -L . -L test \
+ -l test/swift-mode-test.el \
+ -f swift-mode:run-test || die "tests failed"
+}