summaryrefslogtreecommitdiff
path: root/app-emacs/swift-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-19 07:00:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-19 07:00:00 +0000
commitc5572b13d51970d6603acd131f27991cc1b66a79 (patch)
tree459c832fa5c0913b9ce0f85eed5e29922cc0425f /app-emacs/swift-mode
parent6e476156e1a0d2f4aa53968c37835c3441301367 (diff)
gentoo auto-resync : 19:11:2022 - 07:00:00
Diffstat (limited to 'app-emacs/swift-mode')
-rw-r--r--app-emacs/swift-mode/Manifest4
-rw-r--r--app-emacs/swift-mode/files/50swift-mode-gentoo.el4
-rw-r--r--app-emacs/swift-mode/metadata.xml13
-rw-r--r--app-emacs/swift-mode/swift-mode-8.6.0.ebuild27
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/swift-mode/Manifest b/app-emacs/swift-mode/Manifest
new file mode 100644
index 000000000000..24ba3cfbae4e
--- /dev/null
+++ b/app-emacs/swift-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50swift-mode-gentoo.el 176 BLAKE2B 50d8c7580d8b9053bbe94793eb75a80565ed264415a587d7410cfa6259bea9a34b48662f3066abcee9352c2c712aa9d68e8632b23e7511a47947c9b83e64db74 SHA512 3ca3647b549372d5f7493b7eac25ac628f4bc93c6ab6560f724248542ed07557d193a6cf0c2148ea5ed8a7d0d9c9786263c27322daa788894b42c13d7eabdb94
+DIST swift-mode-8.6.0.tar.gz 226530 BLAKE2B c3e7a8912a0afbd62adc702f3692ecd4fd8f6938ab838f9e576969f50ded6e32040c33595c61974eb6778bb68ad9d4d0dbc3f5fd1a296a0836829ba93a75158f SHA512 5e8f4d2874dee93b47b4d5a191af7158a2b61f632e3838b0c8617020abc44736f51de40426f5e0bcb8a46844beaf6be310ed9e655fc7638eed3bff0aa78eb101
+EBUILD swift-mode-8.6.0.ebuild 664 BLAKE2B 7226935f2861e1e905ce8408aeafafd45992f47429b762abcdd4926680bffc247886d1f2c5092f26db113a33e4641d0de36f9582b237ecf0fe00e21e95cca335 SHA512 77a1667bd4007308a09c13855415ce48772628408fedee89501b0f7dbf09c911896be73109088fcb335206b0e27cfae39f22cc01592483df394e5de2f0a61d17
+MISC metadata.xml 433 BLAKE2B 3af7d408604487fd4253efc78148c0607887c01285a6f0c9eb990bda8ca04b27c6ede80c9816ce4263b714a13da4bd654c05d860a57ece4bb0d685f22a4b9922 SHA512 97bab4e8f2c699941c1d3fe30f0d46afa3b7eb19d1a827df0ded5c5c526f7443cd792cb1b1b346936888b8f0a02775e67f2a1afdaca0bfbe2e2dd74852172619
diff --git a/app-emacs/swift-mode/files/50swift-mode-gentoo.el b/app-emacs/swift-mode/files/50swift-mode-gentoo.el
new file mode 100644
index 000000000000..fa55ed725c57
--- /dev/null
+++ b/app-emacs/swift-mode/files/50swift-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'swift-mode "swift-mode"
+ "Major mode for editing Swift code." t)
+(add-to-list 'auto-mode-alist '("\\.swift\\'" . swift-mode))
diff --git a/app-emacs/swift-mode/metadata.xml b/app-emacs/swift-mode/metadata.xml
new file mode 100644
index 000000000000..431933b41555
--- /dev/null
+++ b/app-emacs/swift-mode/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/swift-emacs/swift-mode/issues/</bugs-to>
+ <remote-id type="github">swift-emacs/swift-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/swift-mode/swift-mode-8.6.0.ebuild b/app-emacs/swift-mode/swift-mode-8.6.0.ebuild
new file mode 100644
index 000000000000..ff1d4a1bc14c
--- /dev/null
+++ b/app-emacs/swift-mode/swift-mode-8.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Emacs support for Apple's Swift programming language"
+HOMEPAGE="https://github.com/swift-emacs/swift-mode/"
+SRC_URI="https://github.com/swift-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md CONTRIBUTING.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} \
+ -L . -L test \
+ -l test/swift-mode-test.el \
+ -f swift-mode:run-test || die "tests failed"
+}