summaryrefslogtreecommitdiff
path: root/app-emacs/ssass-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
commiteb509e1a15f595f667e8d177ddb73311084af6c0 (patch)
treefbc083f793d438d54b7fb4ec3a7e0286701b81bb /app-emacs/ssass-mode
parenteedf7b9dec39b69b43f7b581da418d37428db449 (diff)
gentoo auto-resync : 21:05:2023 - 20:55:01
Diffstat (limited to 'app-emacs/ssass-mode')
-rw-r--r--app-emacs/ssass-mode/Manifest4
-rw-r--r--app-emacs/ssass-mode/files/50ssass-mode-gentoo.el3
-rw-r--r--app-emacs/ssass-mode/metadata.xml19
-rw-r--r--app-emacs/ssass-mode/ssass-mode-0.2_p20200211.ebuild21
4 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/ssass-mode/Manifest b/app-emacs/ssass-mode/Manifest
new file mode 100644
index 000000000000..c420ccdcc44b
--- /dev/null
+++ b/app-emacs/ssass-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50ssass-mode-gentoo.el 100 BLAKE2B e246459d7e11d988c74b1b472d7524b64c9471019a902513f5fbd245ef075390a8342f547b2d015c7177fa3dcb3490359a1b86dc39cb53ba8d1477783634c457 SHA512 87df2e8a75b5ad5294afaf73497845132e675fe4194454394d631a714d903a9b828e5f86da15be362d6f595450f16111584d1df9dd8f04ad94049dae4a5c26ca
+DIST ssass-mode-0.2_p20200211.tar.gz 15364 BLAKE2B cdf2b48c3cbb861d89b29673ba3bbcfc2149850086227d58b8d6919f0d7d77914942fe8318e77e96f29e6fea5aeeba9e93c1fd3afbf6e669017e93e0c8de646b SHA512 5e3f2effc4ffb7534811f263cae970c2c7f6d96706cbd11f628f4267acca89550b2ced37f1968c76e32b55cd2dfea9976a11901817de8d5af965ffe4df436a4b
+EBUILD ssass-mode-0.2_p20200211.ebuild 541 BLAKE2B bdf49ed810585e7017397d8588558903f975bd72b48b1d1b3732e37c588dceccb7005018dd44673539edeeb4256d73f01af46e44297a84275000f59a0681f142 SHA512 038ed13fc2257eeb538a463a569103214d2842772a3024f55ce4aec1a2c7708c5c6cafede6f4b04c67e3c554c167271f9ca36456b61536460d920059d226eb75
+MISC metadata.xml 671 BLAKE2B 2c9cf822807ca607add60a068b45935d17ad8772a83bd5f2718373fe9a50ad0a6483ceb032d65f62217a9185abb9010003521de09e43b03921095333fe85e036 SHA512 dcc1accfffdee08fda62d1687c2a21a6ed0c2430f7ed23e13ead69d68927c94f3df30abaef24952099c5c75afd2e59d6dc8e9ca0e9170f5830bbac5c65dbd2ec
diff --git a/app-emacs/ssass-mode/files/50ssass-mode-gentoo.el b/app-emacs/ssass-mode/files/50ssass-mode-gentoo.el
new file mode 100644
index 000000000000..cb9781f2f567
--- /dev/null
+++ b/app-emacs/ssass-mode/files/50ssass-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ssass-mode "ssass-mode"
+ "Major mode for Sass" t)
diff --git a/app-emacs/ssass-mode/metadata.xml b/app-emacs/ssass-mode/metadata.xml
new file mode 100644
index 000000000000..2b6d61246ac1
--- /dev/null
+++ b/app-emacs/ssass-mode/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This mode is a clean-room clone of Natalie Weizenbaum's sass-mode, with a
+ few compromises to support mmm-mode. If sass-mode doesn't break for you,
+ use that.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/AdamNiederer/ssass-mode/issues/</bugs-to>
+ <remote-id type="github">AdamNiederer/ssass-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/ssass-mode/ssass-mode-0.2_p20200211.ebuild b/app-emacs/ssass-mode/ssass-mode-0.2_p20200211.ebuild
new file mode 100644
index 000000000000..5bf8db2af8ae
--- /dev/null
+++ b/app-emacs/ssass-mode/ssass-mode-0.2_p20200211.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ ${PV} == *_p20200211 ]] && COMMIT=96f557887ad97a0066a60c54f92b7234b8407016
+
+inherit elisp
+
+DESCRIPTION="Write Sass in Emacs without a Turing Machine"
+HOMEPAGE="https://github.com/AdamNiederer/ssass-mode/"
+SRC_URI="https://github.com/AdamNiedererw/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"