summaryrefslogtreecommitdiff
path: root/app-emacs/sml-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/sml-mode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/sml-mode')
-rw-r--r--app-emacs/sml-mode/Manifest4
-rw-r--r--app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el2
-rw-r--r--app-emacs/sml-mode/metadata.xml9
-rw-r--r--app-emacs/sml-mode/sml-mode-6.4.ebuild23
4 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/Manifest b/app-emacs/sml-mode/Manifest
new file mode 100644
index 000000000000..c52b6136accd
--- /dev/null
+++ b/app-emacs/sml-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50sml-mode-gentoo-6.1.el 72 BLAKE2B e4b7e4fa2f440410e323da54183257aff3bf555ebaa5e1d3d579375b9bbc5e77bfa1af68e4d305013ca07d9a16df2618d3b5eca6035a42810f87f3abf8bfbab0 SHA512 f8b15038063e9419a5dbcb9b98696df8d431d86806e06d24645671d3c3b5b79c3c31e32330efbbbc0b72a38c841273a14f998bb62ca0cacaf3483507ec8d7444
+DIST sml-mode-6.4.el.xz 20512 BLAKE2B ec82b44e7e1ff9d4c89ffdec6d29afddb2bb5a62474dfef417409496fd374373aca53f3a850990972e888ec2dc006606a06c63e327316e28552273d7995cd38e SHA512 238c69cf34bdd9b825fdc00e65741a458e64bf4bf38ed96ba0518154dd92f25877d56d09f4c13271577ea8641ca828023db950db07a42fe1a02659527b65cb5b
+EBUILD sml-mode-6.4.ebuild 500 BLAKE2B b55d6c334be8bd80667740d582d2e3f18dab432fa5a559f900f2b2528f4c3e256972842d45bf92e1a73fbb9178aa0388e9d6bdda87f107345dfa9a2dd07fb671 SHA512 a1d7a446d46b78b50efd2d907efab0aa2363fc2742602e7c183cb8770d994c931597b6ae15c194da1b9d0909de26b1561c12a7e289e600f969772cdeca8f8590
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el b/app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el
new file mode 100644
index 000000000000..feb0eb3a9551
--- /dev/null
+++ b/app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "sml-mode-autoloads" nil t)
diff --git a/app-emacs/sml-mode/metadata.xml b/app-emacs/sml-mode/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/sml-mode/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/sml-mode/sml-mode-6.4.ebuild b/app-emacs/sml-mode/sml-mode-6.4.ebuild
new file mode 100644
index 000000000000..7eb5bbb42718
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from https://elpa.gnu.org/packages/${P}.el
+SRC_URI="mirror://gentoo/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+
+SITEFILE="50${PN}-gentoo-6.1.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}