summaryrefslogtreecommitdiff
path: root/app-emacs/sml-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-emacs/sml-mode
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-emacs/sml-mode')
-rw-r--r--app-emacs/sml-mode/Manifest2
-rw-r--r--app-emacs/sml-mode/sml-mode-6.10.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/Manifest b/app-emacs/sml-mode/Manifest
index dfc8fb11bc26..a07cd115947b 100644
--- a/app-emacs/sml-mode/Manifest
+++ b/app-emacs/sml-mode/Manifest
@@ -1,4 +1,6 @@
AUX 50sml-mode-gentoo-6.1.el 72 BLAKE2B e4b7e4fa2f440410e323da54183257aff3bf555ebaa5e1d3d579375b9bbc5e77bfa1af68e4d305013ca07d9a16df2618d3b5eca6035a42810f87f3abf8bfbab0 SHA512 f8b15038063e9419a5dbcb9b98696df8d431d86806e06d24645671d3c3b5b79c3c31e32330efbbbc0b72a38c841273a14f998bb62ca0cacaf3483507ec8d7444
+DIST sml-mode-6.10.el.xz 20544 BLAKE2B c872b33ffb9298dfa102b97d33604c68610d73942698b1162ed5b73fc3107217d453c475c9b0bd51368b5f32f82c147ab8de1990e4277f878837824b5dd004b8 SHA512 49e93cb2d317f0e71bfe66a6b206515eaad2cb5173552e96690fc208e9dd0c448f9939e28cd5268f0e9a90278b821109231885452785345698bee9511577828c
DIST sml-mode-6.9.el.xz 20368 BLAKE2B 5b97c6620d97a60f29e21e8d69179e33f56b7410bf975238e23ef10d4c9e8d7dc250cb60d1799224ac6c81285f539cbb7f69b616763b347ed7140b9652b9add7 SHA512 e04143e1017317d6c6fb3ad7a26cd812bb45dd406a5fb679be21ae936ab57739bcf692585d5710a8e08c469a07728a20cb71ff1b53661c4040eb16df55c8be0b
+EBUILD sml-mode-6.10.ebuild 565 BLAKE2B dec2b627bce6ff88f73a17a4ddbc91ab1a61535d4602331388205cdd82d8b91bbe51135f0187fd48b9a2dc53ad7792ca895633ce07bf7671cefcd8c76dc35e9e SHA512 e3828a62917eae4d0b5167f9f3bc18ba5f10aaf4a3b345a5eaaa52dbfa1dc0759391a519562a1d2161df59d197ef4cba323505cdc051e21950d42a3fad85f7da
EBUILD sml-mode-6.9.ebuild 565 BLAKE2B a59481c42813978a06e34b2fab80d759c7dd476d66f9db6f4f54a4438ea0f67142b0385893cb5b7184819747bf61a93058772c3c95f8ae23aa11982bcec8c762 SHA512 7d4216f8270b1cbff4abb0ab363e6bcabd4578d94f24f3ceeed003bd739b476c1e5526cf91bef67361a18ae81d2a3438222227d646426bec945a7e2fddbe7c9a
MISC metadata.xml 283 BLAKE2B 81c49021199f71096079a27f9121390fb8c1285c54b9478583ff2d647277fa106ef12456d7097c4be092fc48b514a1adcf855ca0fac911598232ef9eb7f102c0 SHA512 f32b303760addf5d4db8d18bd10fb677353cdfa4c5e545d47804ef756cf5e5a21f8b8efb631b08f802185913ceb98da820e404e06eb03d01fe9ea85c10d1ac13
diff --git a/app-emacs/sml-mode/sml-mode-6.10.ebuild b/app-emacs/sml-mode/sml-mode-6.10.ebuild
new file mode 100644
index 000000000000..25af30594232
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="https://elpa.gnu.org/packages/sml-mode.html
+ http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from https://elpa.gnu.org/packages/${P}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc x86"
+
+SITEFILE="50${PN}-gentoo-6.1.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}