summaryrefslogtreecommitdiff
path: root/app-emacs/shell-split-string
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/shell-split-string
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/shell-split-string')
-rw-r--r--app-emacs/shell-split-string/Manifest4
-rw-r--r--app-emacs/shell-split-string/files/50shell-split-string-gentoo.el1
-rw-r--r--app-emacs/shell-split-string/metadata.xml13
-rw-r--r--app-emacs/shell-split-string/shell-split-string-0.1.ebuild22
4 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/shell-split-string/Manifest b/app-emacs/shell-split-string/Manifest
new file mode 100644
index 000000000000..b34532333222
--- /dev/null
+++ b/app-emacs/shell-split-string/Manifest
@@ -0,0 +1,4 @@
+AUX 50shell-split-string-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST shell-split-string-0.1.tar.gz 3453 BLAKE2B 3907501aff6aeee821050980b0c65612e0b76bfc3dc98735d70b2bdabd4bd19d1225d4e5c85bc2910e795e53715d2dfc49b900c24f8ed6bb63751e8e25e41c89 SHA512 55b76a4664cecb1c894559efd8270a567868f1e758b55ea23480cfdb550009af0042d69302b7ac7b73eef54e01c01e9978bfb5421d2db3806a4054e3b7e8f893
+EBUILD shell-split-string-0.1.ebuild 493 BLAKE2B 605e930313d97d752a61c46f68451999d4ce7d28ab492b9b9477637c0ad94a9466cebc0bb192b768382268ca6446124ddd427a7e2ce7a74b243c911865aad145 SHA512 b8ac4a2db8c29b85be2b2eb53ae665ed4d3105d22f4c2cbebdca305149748c7b05bf508d305fca3acf88f8efb5c52d22236da6136c71bc546169a5d111bda889
+MISC metadata.xml 441 BLAKE2B 1340cce7a59a00e5bd2074459c28e821681fcf8900726d4df588dea2ddaafc7e3221c1835d4ad3ecac9723f9799959704fb3ece5079fa83f3a73c99dacc29ce7 SHA512 0baaea911ee3ff150279289e44e8ae3fbd1e63f3910990e272ca969cfcbb8ecbeaae02531dc191eda87b975a3a7ad9b24a6fc8e4b99f52bdb8f70c54bf350a31
diff --git a/app-emacs/shell-split-string/files/50shell-split-string-gentoo.el b/app-emacs/shell-split-string/files/50shell-split-string-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/shell-split-string/files/50shell-split-string-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/shell-split-string/metadata.xml b/app-emacs/shell-split-string/metadata.xml
new file mode 100644
index 000000000000..4f91116c53ca
--- /dev/null
+++ b/app-emacs/shell-split-string/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/10sr/shell-split-string-el/issues/</bugs-to>
+ <remote-id type="github">10sr/shell-split-string-el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/shell-split-string/shell-split-string-0.1.ebuild b/app-emacs/shell-split-string/shell-split-string-0.1.ebuild
new file mode 100644
index 000000000000..1538d8985c5d
--- /dev/null
+++ b/app-emacs/shell-split-string/shell-split-string-0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Split Strings Using Shell-Like Syntax"
+HOMEPAGE="https://github.com/10sr/shell-split-string-el/"
+SRC_URI="https://github.com/10sr/${PN}-el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-el-${PV}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake emacs=${EMACS} test
+}