summaryrefslogtreecommitdiff
path: root/app-emacs/rust-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/rust-mode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/rust-mode')
-rw-r--r--app-emacs/rust-mode/Manifest4
-rw-r--r--app-emacs/rust-mode/files/50rust-mode-gentoo.el3
-rw-r--r--app-emacs/rust-mode/metadata.xml9
-rw-r--r--app-emacs/rust-mode/rust-mode-0.3.0_p20180221.ebuild28
4 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/rust-mode/Manifest b/app-emacs/rust-mode/Manifest
new file mode 100644
index 000000000000..1fb7e309e1cd
--- /dev/null
+++ b/app-emacs/rust-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50rust-mode-gentoo.el 135 BLAKE2B 083a273140a659c1a76c05178990ffe4b0f3ae2ede81878ce8cfaab451df4a5169cea46fa4600e57ea77a9a7d55571cb7c862098e5ee76677dd73213e6a30036 SHA512 bd6f7579408d26900d40e674ff75bac2d1989c9bd068dae4bd4c54271e7b04cfcdf4d7d3622955f949cb60496a0d055f5f436084975bb624415b46ddb330f0fe
+DIST rust-mode-0.3.0_p20180221.tar.xz 37392 BLAKE2B 185511a2096400254e141f213f2e9a84861c2aaf5f2259cab724aa929e07b2691ae6f36c5568de5d978809588271486377a194a77a066413df6ee995e9bbe54a SHA512 004bd1536ab2e1e708193509a307ed47e22bf1f3dc5d84816958588e312c8bf6e75ee178cc99439ec0bd427ba02030c133bb21f96c5116b175d1d7cde89e9e6c
+EBUILD rust-mode-0.3.0_p20180221.ebuild 679 BLAKE2B da7156d08130a1d2a2b3970f79381f3dcf317770c07537a4c9f6c7cf06d60daafbd4c9091257c36bffa7b56a5a0fc876ba306eb7ce723f6caf897e27f04874d2 SHA512 d97e2791fa05253774fa0bb8ced86205198c22b0a86123e2b6b15631626671b99b3ec3aaf48bd1d71b1bef7574c26e43f7bf0e568f59949c068485b38c9e159a
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/rust-mode/files/50rust-mode-gentoo.el b/app-emacs/rust-mode/files/50rust-mode-gentoo.el
new file mode 100644
index 000000000000..0df93798a429
--- /dev/null
+++ b/app-emacs/rust-mode/files/50rust-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'rust-mode "rust-mode" nil t)
+(add-to-list 'auto-mode-alist '("\\.rs\\'" . rust-mode))
diff --git a/app-emacs/rust-mode/metadata.xml b/app-emacs/rust-mode/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/rust-mode/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/rust-mode/rust-mode-0.3.0_p20180221.ebuild b/app-emacs/rust-mode/rust-mode-0.3.0_p20180221.ebuild
new file mode 100644
index 000000000000..a061b8c60336
--- /dev/null
+++ b/app-emacs/rust-mode/rust-mode-0.3.0_p20180221.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A major emacs mode for editing Rust source code"
+HOMEPAGE="https://github.com/rust-lang/rust-mode"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -l rust-mode.el -l rust-mode-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp-install ${PN} rust-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}