summaryrefslogtreecommitdiff
path: root/app-emacs/riece/riece-9.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-emacs/riece/riece-9.0.0-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-emacs/riece/riece-9.0.0-r1.ebuild')
-rw-r--r--app-emacs/riece/riece-9.0.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/riece/riece-9.0.0-r1.ebuild b/app-emacs/riece/riece-9.0.0-r1.ebuild
new file mode 100644
index 000000000000..3b436838898f
--- /dev/null
+++ b/app-emacs/riece/riece-9.0.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="A redesign of Liece IRC client"
+HOMEPAGE="https://www.nongnu.org/riece/"
+SRC_URI="https://download.savannah.gnu.org/releases/riece/${P}.tar.gz"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="l10n_ja"
+RESTRICT="test"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf --with-lispdir="${EPREFIX}${SITELISP}"
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ lispdir="${ED}${SITELISP}" \
+ install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS NEWS README doc/HACKING lisp/ChangeLog*
+
+ if use l10n_ja; then
+ dodoc NEWS.ja README.ja doc/HACKING.ja
+ else
+ rm -f "${ED}"/usr/share/info/riece-ja.info*
+ fi
+}