summaryrefslogtreecommitdiff
path: root/app-emacs/quilt-el
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/quilt-el
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/quilt-el')
-rw-r--r--app-emacs/quilt-el/Manifest6
-rw-r--r--app-emacs/quilt-el/files/50quilt-el-gentoo.el7
-rw-r--r--app-emacs/quilt-el/files/quilt-el-0.45.4-header-window.patch10
-rw-r--r--app-emacs/quilt-el/files/quilt-el-0.48.0-tramp-recursion.patch11
-rw-r--r--app-emacs/quilt-el/metadata.xml17
-rw-r--r--app-emacs/quilt-el/quilt-el-0.48.0.ebuild21
6 files changed, 72 insertions, 0 deletions
diff --git a/app-emacs/quilt-el/Manifest b/app-emacs/quilt-el/Manifest
new file mode 100644
index 000000000000..6017bf525ef0
--- /dev/null
+++ b/app-emacs/quilt-el/Manifest
@@ -0,0 +1,6 @@
+AUX 50quilt-el-gentoo.el 295 BLAKE2B 2179c4c7635fc79dcfc5444f37c2c38d35468a9c11742f3a162f78dc49c33abe605cb68642b858b0ff6221180f74555f0f5a5833740e757aadd0ad903325de49 SHA512 b14f5b3db3ec93cdb0b95b64295dd5d7d6561db4b71ee691001cab5678922dd2977716f023c8b046e63e2ff6dcc25d5f5dd1dce9571016ac16c86b44529d9417
+AUX quilt-el-0.45.4-header-window.patch 297 BLAKE2B 87d5157dcf03d8975afd0b72d223c2a2133039aecafd9f283ec2729e440fee56719d1ca02be7565c22bc3e1c887ac57677dd771ed4b4d11681e1d21315036bc3 SHA512 fe12a4a4326bf586441b838dbc52bf8bd32fe639208ce5078627f24f13a5e49547ac1361117f8fc9578689d1b953ba2724981b9e563ab14192cdc1d78c59fff5
+AUX quilt-el-0.48.0-tramp-recursion.patch 363 BLAKE2B ca26afa6738d51efd007d46ffb78414d4ae296626905db1ca6b65b09d8946f1e09536a04f4153650763478f4054f07a8dc58e171ed4e613d1a259afcf4214fb1 SHA512 b4369142d70543bbb8139b4f6d8b8c8c13bf2bbd93d1bc87de690c93de485d9000918c6fe7278a32472b2a9afb495f3a9c639434a3edd3489c6cf2bd5f99a5fe
+DIST quilt-el-0.48.0.tar.gz 13147 BLAKE2B 595e7d12c24095df3c0d12de607b4e43e36345b53f9d89e6ea6ea781ed25f893d5100e3a023b4f5bc0aee11dcf93a7ef3862fabe28c8eda98a43dce634969444 SHA512 0a198ef0f8354c927c4527bb7a3e99fd6d12f17cbe65c736341c527de440d144581205337163912ce04f83749c31833221cc4153d5736ffec060ad4ade73c694
+EBUILD quilt-el-0.48.0.ebuild 524 BLAKE2B c09278c3efca977158d8a323911947439c3a7812b2b82d2f4418666c91cf3a56d3febf3e1587c72a602f7fe361233387991c7dfbfa51311b57400085dc190067 SHA512 f9a65f053573d5f561b82728701b09588aa87e42114da625abbacfa53a49d001113a04b122de67b7cc39a295bab9efcab3597d95329826ef1509fdd85e11a879
+MISC metadata.xml 657 BLAKE2B f42a9f750c0914dae5ebf3cf8798857d8bb2b8135597470991dfe3e3644716e47d3079d77754305be689a337609e719ba277e5e0a4119bed5e2ae2272147bebd SHA512 d7e9d85957ad96345d3394977312e5ffbb37c61f7529b7b179c2dfcb1e41208089a469fc5db8760f0f62a6cdb5ddf801e11673d126711569fc2a61bfd8a04e4b
diff --git a/app-emacs/quilt-el/files/50quilt-el-gentoo.el b/app-emacs/quilt-el/files/50quilt-el-gentoo.el
new file mode 100644
index 000000000000..ccdd69d19ab9
--- /dev/null
+++ b/app-emacs/quilt-el/files/50quilt-el-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'quilt-mode "quilt"
+ "Toggle quilt-mode. With positive arg, enable quilt-mode." t)
+(autoload 'quilt-hook "quilt"
+ "Enable quilt mode for quilt-controlled files.")
+(add-hook 'find-file-hooks 'quilt-hook)
+(add-hook 'after-revert-hook 'quilt-hook)
diff --git a/app-emacs/quilt-el/files/quilt-el-0.45.4-header-window.patch b/app-emacs/quilt-el/files/quilt-el-0.45.4-header-window.patch
new file mode 100644
index 000000000000..b2f532617f76
--- /dev/null
+++ b/app-emacs/quilt-el/files/quilt-el-0.45.4-header-window.patch
@@ -0,0 +1,10 @@
+--- quilt-el.orig/quilt.el
++++ quilt-el/quilt.el
+@@ -399,6 +399,7 @@
+ (cd quilt-header-directory)
+ (shell-command (concat "EDITOR=cat quilt -r header <" tmp))
+ (kill-buffer (current-buffer))
++ (delete-window)
+ (delete-file tmp)))
+
+ (defvar quilt-header-mode-map (make-keymap))
diff --git a/app-emacs/quilt-el/files/quilt-el-0.48.0-tramp-recursion.patch b/app-emacs/quilt-el/files/quilt-el-0.48.0-tramp-recursion.patch
new file mode 100644
index 000000000000..aa1bf5c97e8d
--- /dev/null
+++ b/app-emacs/quilt-el/files/quilt-el-0.48.0-tramp-recursion.patch
@@ -0,0 +1,11 @@
+--- quilt-el-0.48.0-orig/quilt.el
++++ quilt-el-0.48.0/quilt.el
+@@ -49,7 +49,7 @@
+
+ (defun quilt-find-dir (fn)
+ "Return the top level dir of quilt from FN."
+- (if (or (not fn) (equal fn "/"))
++ (if (or (not fn) (equal fn (file-name-directory fn)))
+ nil
+ (let ((d (file-name-directory fn)))
+ (if (file-accessible-directory-p (concat d "/.pc"))
diff --git a/app-emacs/quilt-el/metadata.xml b/app-emacs/quilt-el/metadata.xml
new file mode 100644
index 000000000000..a1854035455f
--- /dev/null
+++ b/app-emacs/quilt-el/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ quilt-el is an Emacs minor mode for quilt. By using this, it becomes easy to
+ edit files controlled by quilt. The main features are as follows:
+ * Automatically detects files that are in a quilt hierarchy and enables
+ itself.
+ * Only files in topmost patch can be writable.
+ * Some handy shortcut keys of quilt commands.
+</longdescription>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/quilt-el/quilt-el-0.48.0.ebuild b/app-emacs/quilt-el/quilt-el-0.48.0.ebuild
new file mode 100644
index 000000000000..3cbadd1d144d
--- /dev/null
+++ b/app-emacs/quilt-el/quilt-el-0.48.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp eutils
+
+DESCRIPTION="Quilt mode for Emacs"
+HOMEPAGE="http://satoru-takeuchi.org/dev/quilt-el/"
+SRC_URI="http://satoru-takeuchi.org/dev/${PN}/download/${P}.tar.gz"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 sparc x86"
+
+RDEPEND="dev-util/quilt"
+
+ELISP_PATCHES="${P}-tramp-recursion.patch
+ ${PN}-0.45.4-header-window.patch"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README changelog"