summaryrefslogtreecommitdiff
path: root/app-emacs/queue
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-emacs/queue
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-emacs/queue')
-rw-r--r--app-emacs/queue/Manifest4
-rw-r--r--app-emacs/queue/files/50queue-gentoo.el1
-rw-r--r--app-emacs/queue/metadata.xml16
-rw-r--r--app-emacs/queue/queue-0.2.ebuild17
4 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/queue/Manifest b/app-emacs/queue/Manifest
new file mode 100644
index 000000000000..52d2b03ec0cb
--- /dev/null
+++ b/app-emacs/queue/Manifest
@@ -0,0 +1,4 @@
+AUX 50queue-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST queue-0.2.el.xz 2168 BLAKE2B 4c6c89ffa66d1bc5da11b78b6965077922384090327360c5b787508d9248051a6e3371b1e6ae5dd0fc8337d4623cbcb07d44d0f6147b29f14da8a3900868bd94 SHA512 62e43482db9828fe6f6d58c95389cd93642a6019211b190dd8f862efa6011708ad8e9a6c025ddb2e663effe0a8aec2f72f42f1afcaaf4c7d64fe698c274eef39
+EBUILD queue-0.2.ebuild 370 BLAKE2B a4ed42454e96b0943e59f824c7fcb96e4fda17de0805e1aaeecdf965d5be6cd4bd8fb63ec3ca5089ced05dca6946a02c97772dd1b2d9a4cf6d874b53160ffdd5 SHA512 a13fb24bd5a4dc4992cc1918f42bb34e54bf062617bcc9d85a137d1692a5052bcdd4e8b6c5ddd2bf6cb49f6edd07e2554f6f950837f20b40afec044b57f53a3c
+MISC metadata.xml 646 BLAKE2B 531439627cabcb6165701fc8888c2eb76a6caf155a4694c260bb76208bc39f253f78bded1cd6d06e0c5e1fbbafcebfa9ade2aedf90e13a4b222ebd944dc671e0 SHA512 5c9eb05a114d76b07759d6c5627bd00f2c447c4ccde2b6856dbaf715cb59a81af79cf88d2ce8d6abbd6d9e9b668ab76f8e537313f52def38bd8fb4dfa5e14516
diff --git a/app-emacs/queue/files/50queue-gentoo.el b/app-emacs/queue/files/50queue-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/queue/files/50queue-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/queue/metadata.xml b/app-emacs/queue/metadata.xml
new file mode 100644
index 000000000000..3ac8e09b5ce7
--- /dev/null
+++ b/app-emacs/queue/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Provides queues can be used both as a first-in last-out (FILO) and
+ as a first-in first-out (FIFO) stack, i.e. elements can be added to
+ the front or back of the queue, and can be removed from the
+ front. (This type of data structure is sometimes called an
+ "output-restricted deque".)
+ </longdescription>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/queue/queue-0.2.ebuild b/app-emacs/queue/queue-0.2.ebuild
new file mode 100644
index 000000000000..5b87345f6b8f
--- /dev/null
+++ b/app-emacs/queue/queue-0.2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Queue data structure"
+HOMEPAGE="https://elpa.gnu.org/packages/queue.html"
+SRC_URI="https://dev.gentoo.org/~matthew/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"