summaryrefslogtreecommitdiff
path: root/app-emacs/quack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/quack
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/quack')
-rw-r--r--app-emacs/quack/Manifest4
-rw-r--r--app-emacs/quack/files/50quack-gentoo.el10
-rw-r--r--app-emacs/quack/metadata.xml9
-rw-r--r--app-emacs/quack/quack-0.47.ebuild16
4 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/quack/Manifest b/app-emacs/quack/Manifest
new file mode 100644
index 000000000000..98354b0d2188
--- /dev/null
+++ b/app-emacs/quack/Manifest
@@ -0,0 +1,4 @@
+AUX 50quack-gentoo.el 443 BLAKE2B 54f22bb597de98c092a0f520f0da43ecb1c0b3775aa49058c6210116f0cb9a4820a4b29703e1b64cb6975984b3c5be596b5d94efbd0639c67208e864ec37e49f SHA512 724a1903e7c801e59af487059373225ab5c9da02bb912364566dcd468f06067aa722061bb5e1c9284cfae200538550d3e5fbee24de997720f47af4cae10f90d7
+DIST quack-0.47.el.xz 44508 BLAKE2B 36b05926e019d191a21bac6e8e0d8f2c0228a4decee807f3ed61b145db56af5bdede43708c5e04d1f65f261b7de645a40a02a95f0300b8673b454293011903e9 SHA512 41775f5850518a8738aae9d7185c733ad4d5a778859a9d9a7235c84184fb7b84dd49d37a607291f39fac4ddc1cd507806a01dd19ab3351646ecf35e747feb8ce
+EBUILD quack-0.47.ebuild 368 BLAKE2B 5e126718546977ff957d913e5bd7956955cf6fab08ca976074350ce176a044c462c796c39ac06e855a032ca680fa0d94e8fdc61f9fcd477cd2a81f3489bbd0c0 SHA512 8d41f0d20afb492fcf9dc8814e5ec5970ac199422728a4d27da3918a226f424ef0f2845fdd89c62113f63a3d68a1096eb8da5828a8746c5606a2575cc667f176
+MISC metadata.xml 282 BLAKE2B 432e60a3b04def9f566fde3852011e006c0d578c72c42115734d1af5c128440fcee68134c8f891baad437e64a8d61fbbac49e70a35ed4f6f85641e888d3a2547 SHA512 1838e22e1f5b849b816a05d1b25bd81333c8cf67ceb996177e05ba7a555b8e0e307e62cb53e6f1217f4216823e2fecf050e85437678503d60e10c6b2d5303072
diff --git a/app-emacs/quack/files/50quack-gentoo.el b/app-emacs/quack/files/50quack-gentoo.el
new file mode 100644
index 000000000000..22cca093d956
--- /dev/null
+++ b/app-emacs/quack/files/50quack-gentoo.el
@@ -0,0 +1,10 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'quack-scheme-mode-hookfunc "quack")
+(autoload 'quack-inferior-scheme-mode-hookfunc "quack")
+(autoload 'quack-pltfile-mode "quack"
+ "Major mode for viewing PLT Scheme `.plt' package files." t)
+
+(add-hook 'scheme-mode-hook 'quack-scheme-mode-hookfunc)
+(add-hook 'inferior-scheme-mode-hook 'quack-inferior-scheme-mode-hookfunc)
+(add-to-list 'auto-mode-alist '("\\.plt\\'" . quack-pltfile-mode))
diff --git a/app-emacs/quack/metadata.xml b/app-emacs/quack/metadata.xml
new file mode 100644
index 000000000000..c918cdef9591
--- /dev/null
+++ b/app-emacs/quack/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/quack/quack-0.47.ebuild b/app-emacs/quack/quack-0.47.ebuild
new file mode 100644
index 000000000000..2cae951f4432
--- /dev/null
+++ b/app-emacs/quack/quack-0.47.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Enhances Emacs support for Scheme"
+HOMEPAGE="http://www.neilvandyke.org/quack/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"