summaryrefslogtreecommitdiff
path: root/app-emacs/python-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /app-emacs/python-mode
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/Manifest2
-rw-r--r--app-emacs/python-mode/python-mode-6.3.0.ebuild20
2 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/python-mode/Manifest b/app-emacs/python-mode/Manifest
index 16bd35e66cfd..f348b4b968c9 100644
--- a/app-emacs/python-mode/Manifest
+++ b/app-emacs/python-mode/Manifest
@@ -1,4 +1,6 @@
AUX 50python-mode-gentoo.el 541 BLAKE2B a1657fc49011246ba1cfed1cd8993a222c4932516c6a8e3be4fcc53200510ad8e9a3e1072c2bce641cded4be1581a9c950991d6864c2136668ddba4de8f2429d SHA512 8e1c2c68409c48f3e7c2ae36128380fd5358a12470db571ffa22b1c9cb11730a2f2a84ec66f23c064e32b504c8ae002033e77640d85e11577c50e31462cd5274
+DIST python-mode-6.3.0.tar.bz2 377148 BLAKE2B f55620dcda63bb074116ad622d0ac2431839277a9f525be857bb4245a6b5b9f7daaefd538e166efb327333bb2186f2998541f3a1816bff76c65a726e78265c01 SHA512 cc4a9e67ec3d751040a1ee453360f7aad127688db9c67385b669aa76ad7504dfea1b15408f4ff130a5103f5266ee4eeb920e66b1c1fd1f2dcbfe6302cc8f847a
DIST python-mode.el-6.2.3.tar.gz 314461 BLAKE2B 3bd71b47de1284d59db61f829e3419f2fb10e226900392d903256f31ad90f47317b7bde4cde1cf7d86518f9c706d9c844b208a9e2469a41037252a63f7bc1ba6 SHA512 4aeb33d4054d582cd2a3f4834472c7d0cb3fe5e12e10f5117dcbcd90ec2ca490964c774918c83697f283c68e57766c3c67d3853ddbaa3408777fdafc7f2674f2
EBUILD python-mode-6.2.3.ebuild 686 BLAKE2B 198606ca07bfd459b226a8b555bc14a82e54d5d7b23fbee377cc80851a34f54c0dcb3ea86cfb0b9741a4ae45fc833faa06aa6e8d6e5833cad37a97224edfc98c SHA512 8c34226a45a852fb468cab7c87ceb9f96c422626e0a24f05e9472c2486381cd7f3d31fefc93555b4d7df8e1a7eb781736d253f679e07d1064541bd99d679974e
+EBUILD python-mode-6.3.0.ebuild 713 BLAKE2B 038ceb3b3515efdf5ab7be45bfaafd4865f48f90337662bfcb67bced764e3bd2ec5584af2899291ea0aa7289d94c0efd5da18a84f24a5638e9ee3d0bf4a1eedb SHA512 2bc1c6de00426fe11791ad2fdbe03306de936348d203df49a318e2ecbfdf2d9495c28b902276b895a5e6b247a6870f288836529b39450e4de4559bc2d648917e
MISC metadata.xml 360 BLAKE2B 45f8523f260073dea339ca644560c2b44187bc4c01037fe63caf546406f0f8ebc016a9cb4f99039bcacd99a7ea96e4a8e529e43632d7ad8c5a9a3c65d75f503c SHA512 705c854935095cd9d3eb54cca4cb23e15a3727337a2b8ef9d7b92dbc11bfd068836e739e399490f01619bac7f4ec5475ea29f74d1f319a93e33a7db465f510c2
diff --git a/app-emacs/python-mode/python-mode-6.3.0.ebuild b/app-emacs/python-mode/python-mode-6.3.0.ebuild
new file mode 100644
index 000000000000..2dd18ba0b96c
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://gitlab.com/python-mode-devs/python-mode"
+SRC_URI="https://gitlab.com/python-mode-devs/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+ELISP_REMOVE="python-mode-pkg.el"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="CONTRIBUTING.md CREDITS NEWS *.org"
+DOC_CONTENTS="Note that doctest and pymacs are in their own packages,
+ app-emacs/doctest-mode and app-emacs/pymacs, respectively."