summaryrefslogtreecommitdiff
path: root/app-emacs/pymacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/pymacs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/pymacs')
-rw-r--r--app-emacs/pymacs/Manifest4
-rw-r--r--app-emacs/pymacs/files/50pymacs-gentoo.el5
-rw-r--r--app-emacs/pymacs/metadata.xml15
-rw-r--r--app-emacs/pymacs/pymacs-0.25-r2.ebuild54
4 files changed, 78 insertions, 0 deletions
diff --git a/app-emacs/pymacs/Manifest b/app-emacs/pymacs/Manifest
new file mode 100644
index 000000000000..e1cd1971cc1f
--- /dev/null
+++ b/app-emacs/pymacs/Manifest
@@ -0,0 +1,4 @@
+AUX 50pymacs-gentoo.el 183 BLAKE2B f1a4b874bb339b653c4fb6fb186bd7e531151c34d1df58be6963288d4443438fcae0f82c92a1667b4e7cb739bc2f7c6fd8d8d5f6d4e91413ee5bec47a609cc2e SHA512 f59fed86f859b796c901088b38fb570a5e5527d774a15456105ce75598c31fd20d0afaa62ad9cbf12063810fa592dbbd7c33aaece5871b36b488e5af6de0fac2
+DIST pymacs-0.25.tar.gz 120597 BLAKE2B 837c67d862c11d2a9d74cb55a055f60627834a50717d5386ec604db70a62270aa2ad3e56942602dc10a5f997ab3ce6d7f91e29a8c5b959144286182ad861b3bb SHA512 e17f7ee754413e21403d23894ee263fb0edae180a60c746b02cf101b2f0c782116e7bb61215bd0a8c689a991e211d780d220d4672b58f43108e7218a6f0c8dc0
+EBUILD pymacs-0.25-r2.ebuild 1279 BLAKE2B bb728892bc5a2386f9ec663a137666f1c9c46632c4d9d086ddfdff2b0f1797e997ddef54a3a35c0cc02c86db9616ad687d357a5997e012eb7251db3b89f597d3 SHA512 30c8a587a138564a9a2def942b83be10ee6f55e776dbd90199461b28669e13a705316fef347c4b68947b9e0a53273215dd9bb59c6baa2bd6ea7ee05e7a41fe2d
+MISC metadata.xml 434 BLAKE2B 11fe7bc8c9fa32f4762237f30e93ae5281b73b10a99e389d6cad284f6ba649b7f732fd07aefec8f50d7175af301e021ad34cfac65adfbfb7dc6133184725cbb2 SHA512 899211703ed0824e0b2dd26018e46854ab970d76ee12f169b99bc3a49f9e3bfb1d42757c35ac1ac21268b90b8536737aab61cf9dd4f7297b4e5360f1fe73f821
diff --git a/app-emacs/pymacs/files/50pymacs-gentoo.el b/app-emacs/pymacs/files/50pymacs-gentoo.el
new file mode 100644
index 000000000000..8c59be7e3365
--- /dev/null
+++ b/app-emacs/pymacs/files/50pymacs-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'pymacs-load "pymacs" nil t)
+(autoload 'pymacs-eval "pymacs" nil t)
+(autoload 'pymacs-apply "pymacs")
+(autoload 'pymacs-call "pymacs")
diff --git a/app-emacs/pymacs/metadata.xml b/app-emacs/pymacs/metadata.xml
new file mode 100644
index 000000000000..f928f5ea6cdb
--- /dev/null
+++ b/app-emacs/pymacs/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">pinard/Pymacs</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/pymacs/pymacs-0.25-r2.ebuild b/app-emacs/pymacs/pymacs-0.25-r2.ebuild
new file mode 100644
index 000000000000..edc51a95f82d
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.25-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit elisp distutils-r1 vcs-snapshot
+
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="https://www.emacswiki.org/emacs/PyMacs"
+SRC_URI="https://github.com/pinard/Pymacs/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 arm ~hppa ia64 ppc ppc64 ~s390 ~sh x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="doc? (
+ >=dev-python/docutils-0.7
+ virtual/latex-base )
+"
+RDEPEND=""
+
+DISTUTILS_IN_SOURCE_BUILD=1
+SITEFILE="50${PN}-gentoo.el"
+
+python_prepare_all() {
+ sed \
+ -e '/pymacs-python-command/s/@PYTHON@/python/' \
+ -i pymacs.el.in || die
+ distutils-r1_python_prepare_all
+}
+
+# called by distutils-r1 for every python implementation
+python_configure() {
+ # pre-process the files but don't run distutils
+ emake PYSETUP=: PYTHON=${EPYTHON}
+}
+
+# called once
+python_compile_all() {
+ elisp_src_compile
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake RST2LATEX=rst2latex.py pymacs.pdf
+ fi
+}
+
+python_install_all() {
+ elisp_src_install
+
+ distutils-r1_python_install_all
+ dodoc pymacs.rst
+ use doc && dodoc pymacs.pdf
+}