summaryrefslogtreecommitdiff
path: root/app-emacs/pymacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /app-emacs/pymacs
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'app-emacs/pymacs')
-rw-r--r--app-emacs/pymacs/Manifest1
-rw-r--r--app-emacs/pymacs/pymacs-0.26-r1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/pymacs/Manifest b/app-emacs/pymacs/Manifest
index 76b8f17e56c4..918bb8232886 100644
--- a/app-emacs/pymacs/Manifest
+++ b/app-emacs/pymacs/Manifest
@@ -1,4 +1,5 @@
AUX 50pymacs-gentoo.el 183 BLAKE2B f1a4b874bb339b653c4fb6fb186bd7e531151c34d1df58be6963288d4443438fcae0f82c92a1667b4e7cb739bc2f7c6fd8d8d5f6d4e91413ee5bec47a609cc2e SHA512 f59fed86f859b796c901088b38fb570a5e5527d774a15456105ce75598c31fd20d0afaa62ad9cbf12063810fa592dbbd7c33aaece5871b36b488e5af6de0fac2
DIST pymacs-0.26.tar.gz 123373 BLAKE2B 0c467435d18ebcbe7b263e90096363e201dd84ba770fa702beefac4318a713954c316f335ee005ea88370be29c3710a7df04fb05b6efd3816beedbb88e38126d SHA512 ae245de130f435d947788c5ac11d8ce6534df80f70a4e35fff903f22d2b79b0f66925059ebaf53bde45cd6660ac0a8a224490f4f9e256a84e3a08f6468c14dd2
+EBUILD pymacs-0.26-r1.ebuild 1153 BLAKE2B 7dc1a383a2c9c85e13b6ce77e2436899fb99349bc6230674bd728da7157659f055c77e856f9273c3b2a1e143848af36af9f1ae0a06eb73e51d1d6c6c1d8cbdc4 SHA512 186845389c72f84b09c05499524a9176edd7ea1e58cf0f183c97bc045e7070286f4ae7b9708dae23f3e13c17c9a50edc322af36c6d5e0ab6e90a375a8432dd01
EBUILD pymacs-0.26.ebuild 1329 BLAKE2B 23b29f1fe217da9aa055a84040f0ab17c13a385abfe0d7aa5aeafaffdbc7a6209496affd80b702b0ef9dc12d35c204cd5f02154338f011159110a42765198d2b SHA512 dfafb9317794795ccb26f8c4a21cb59c290da71b76c19ef4f6e3657f35f0b0e5ea7fdc9a1a8e1f628e9ae209295988a1773bf32700657069bf8f1d261b77d7c8
MISC metadata.xml 435 BLAKE2B 10ae4a8b61dfb10339404f38e37cafa1b66737a8f593bc4ba1c626b9d884ebb19dca555dbdf24b1418fec711f6b73865046cf50d58990980ab5115b1755ddd24 SHA512 bb1bdeb6695093fb0788f956059a6e081b98d8b769e2d336057954e85006dac277b756206f83565d52c2473dc45f3afb1087850e38843103f0ef7581a634eec0
diff --git a/app-emacs/pymacs/pymacs-0.26-r1.ebuild b/app-emacs/pymacs/pymacs-0.26-r1.ebuild
new file mode 100644
index 000000000000..0ff10a4675c3
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.26-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit elisp distutils-r1
+
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="https://www.emacswiki.org/emacs/PyMacs"
+SRC_URI="https://github.com/dgentry/${PN^}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+BDEPEND="doc? (
+ >=dev-python/docutils-0.7
+ virtual/latex-base
+ )"
+
+S="${WORKDIR}/${P^}"
+DISTUTILS_IN_SOURCE_BUILD=1
+DISTUTILS_USE_SETUPTOOLS="no"
+SITEFILE="50${PN}-gentoo.el"
+
+# called by distutils-r1 for every python implementation
+python_configure() {
+ # pre-process the files but don't run distutils
+ emake PYSETUP=: PYTHON=${EPYTHON}
+}
+
+# called once
+python_compile_all() {
+ elisp_src_compile
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake RST2LATEX=rst2latex.py pymacs.pdf
+ fi
+}
+
+python_install_all() {
+ elisp_src_install
+ distutils-r1_python_install_all
+ dodoc pymacs.rst
+ use doc && dodoc pymacs.pdf
+}