summaryrefslogtreecommitdiff
path: root/app-emacs/puppet-mode/puppet-mode-0.3.20171221.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
commit22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (patch)
tree808b5701901fb54b53ec3ecf6f33272e933f3ea6 /app-emacs/puppet-mode/puppet-mode-0.3.20171221.ebuild
parent91c0ec2d7067f6ab1ef578bd9967b32ca07eb502 (diff)
gentoo resync : 25.05.2018
Diffstat (limited to 'app-emacs/puppet-mode/puppet-mode-0.3.20171221.ebuild')
-rw-r--r--app-emacs/puppet-mode/puppet-mode-0.3.20171221.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/puppet-mode/puppet-mode-0.3.20171221.ebuild b/app-emacs/puppet-mode/puppet-mode-0.3.20171221.ebuild
new file mode 100644
index 000000000000..2cf8f9430f72
--- /dev/null
+++ b/app-emacs/puppet-mode/puppet-mode-0.3.20171221.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+COMMIT=b3ed5057166a4f49dfa9be638523a348b55a2fd2
+
+DESCRIPTION="Emacs major mode for editing Puppet manifests"
+HOMEPAGE="https://github.com/voxpupuli/puppet-mode"
+SRC_URI="https://github.com/voxpupuli/puppet-mode/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+
+DOCS="CHANGES.md README.md"
+SITEFILE="50${PN}-1-gentoo.el"
+
+# Tests require unpackaged ert-runner
+RESTRICT="test"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed -i -e 's/@VERSION@/'${PV}'/' puppet-mode.el || die
+}